aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libsdl/libsdl-native_1.2.14.bb
diff options
context:
space:
mode:
authorDavid-John Willis <John.Willis@Distant-earth.com>2009-11-28 08:35:32 +0000
committerKoen Kooi <koen@openembedded.org>2009-12-04 10:43:06 +0100
commitf0efa83cf3055a9085171804bb1182ab76eb70f6 (patch)
treebcd65118b2e0b72bd584746ebd6de9f0798af677 /recipes/libsdl/libsdl-native_1.2.14.bb
parentba9ab8c783d196ed16b1b4d64b04ec20845323eb (diff)
downloadopenembedded-f0efa83cf3055a9085171804bb1182ab76eb70f6.tar.gz
libsdl: Add 1.2.14 (and native). Note: Does not use libsdl.inc as that has hacks for older SDL versions.
* Only tested on the OpenPandora under Angstrom currently.
Diffstat (limited to 'recipes/libsdl/libsdl-native_1.2.14.bb')
-rw-r--r--recipes/libsdl/libsdl-native_1.2.14.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes/libsdl/libsdl-native_1.2.14.bb b/recipes/libsdl/libsdl-native_1.2.14.bb
new file mode 100644
index 0000000000..35a73a6d18
--- /dev/null
+++ b/recipes/libsdl/libsdl-native_1.2.14.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "Simple DirectMedia Layer - native Edition"
+HOMEPAGE = "http://www.libsdl.org"
+SECTION = "libs"
+LICENSE = "LGPL"
+PR = "r0"
+
+SRC_URI = "http://www.libsdl.org/release/SDL-${PV}.tar.gz \
+"
+
+S = "${WORKDIR}/SDL-${PV}"
+
+inherit autotools binconfig pkgconfig native
+
+PARALLEL_MAKE = ""
+
+EXTRA_OECONF = "--disable-debug --disable-cdrom --enable-threads --enable-timers --enable-endian \
+ --enable-file --disable-oss --disable-alsa --disable-esd --disable-arts \
+ --disable-diskaudio --disable-nas --disable-esd-shared --disable-esdtest \
+ --disable-mintaudio --disable-nasm --disable-video-x11 --disable-video-dga \
+ --disable-video-fbcon --disable-video-directfb --disable-video-ps2gs \
+ --disable-video-xbios --disable-video-gem --disable-video-dummy \
+ --disable-video-opengl --enable-input-events --enable-pthreads \
+ --disable-video-picogui --disable-video-qtopia --enable-dlopen"
+
+do_configure() {
+ gnu-configize
+ oe_runconf
+ cd ${S}
+ # prevent libtool from linking libs against libstdc++, libgcc, ...
+ cat ${TARGET_PREFIX}libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${TARGET_PREFIX}libtool.tmp
+ mv ${TARGET_PREFIX}libtool.tmp ${TARGET_PREFIX}libtool
+}
+
+do_stage() {
+ autotools_stage_all
+ install -m 0644 build/libSDLmain.a ${STAGING_LIBDIR}
+}