aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libsdl
diff options
context:
space:
mode:
authorDavid-John Willis <John.Willis@Distant-earth.com>2009-12-10 13:47:02 +0000
committerKoen Kooi <koen@openembedded.org>2010-01-06 09:34:54 +0100
commit08463df7fe4a5eebe30c66b4d75c87be494372c5 (patch)
treed2b8083f27ed2283681d0066c07a0e1be7f67189 /recipes/libsdl
parentf08219813b234ee0678fab3adc64b6e6896dd1c2 (diff)
downloadopenembedded-08463df7fe4a5eebe30c66b4d75c87be494372c5.tar.gz
libsdl-image: Add 1.2.10 and checksum and cleanup recipe and add INC_PR.
* Add INC_PR to include and seed higher than highest r4 in existing recipes.
Diffstat (limited to 'recipes/libsdl')
-rw-r--r--recipes/libsdl/libsdl-image.inc3
-rw-r--r--recipes/libsdl/libsdl-image_1.2.10.bb16
-rw-r--r--recipes/libsdl/libsdl-image_1.2.3.bb2
-rw-r--r--recipes/libsdl/libsdl-image_1.2.6.bb3
4 files changed, 21 insertions, 3 deletions
diff --git a/recipes/libsdl/libsdl-image.inc b/recipes/libsdl/libsdl-image.inc
index b52db71511..014dca4382 100644
--- a/recipes/libsdl/libsdl-image.inc
+++ b/recipes/libsdl/libsdl-image.inc
@@ -4,6 +4,8 @@ PRIORITY = "optional"
DEPENDS = "zlib libpng jpeg virtual/libsdl"
LICENSE = "LGPL"
+INC_PR = "r4"
+
SRC_URI = "http://www.libsdl.org/projects/SDL_image/release/SDL_image-${PV}.tar.gz"
S = "${WORKDIR}/SDL_image-${PV}"
@@ -17,4 +19,3 @@ do_stage() {
ln -sf libSDL_image.so ${STAGING_LIBDIR}/libSDL_image-1.2.so
install -m 0644 SDL_image.h ${STAGING_INCDIR}/SDL/SDL_image.h
}
-
diff --git a/recipes/libsdl/libsdl-image_1.2.10.bb b/recipes/libsdl/libsdl-image_1.2.10.bb
new file mode 100644
index 0000000000..bda06456b3
--- /dev/null
+++ b/recipes/libsdl/libsdl-image_1.2.10.bb
@@ -0,0 +1,16 @@
+require libsdl-image.inc
+
+PR = "${INC_PR}.1"
+
+DEPENDS += "tiff"
+
+# Disable the run-time loading of the libs and bring back the soname dependencies.
+EXTRA_OECONF += "--disable-jpg-shared --disable-png-shared -disable-tif-shared"
+
+do_unpackpost() {
+ # Removing this file fixes a libtool version mismatch.
+ rm acinclude/libtool.m4
+ rm acinclude/sdl.m4
+}
+
+addtask unpackpost after do_unpack before do_patch
diff --git a/recipes/libsdl/libsdl-image_1.2.3.bb b/recipes/libsdl/libsdl-image_1.2.3.bb
index 2da8fce1b6..ea3e72c94f 100644
--- a/recipes/libsdl/libsdl-image_1.2.3.bb
+++ b/recipes/libsdl/libsdl-image_1.2.3.bb
@@ -1,6 +1,6 @@
require libsdl-image.inc
-PR = "r2"
+PR = "${INC_PR}.2"
SRC_URI += "\
file://autotools.patch;patch=1 \
diff --git a/recipes/libsdl/libsdl-image_1.2.6.bb b/recipes/libsdl/libsdl-image_1.2.6.bb
index 99fd98f508..9657ba611a 100644
--- a/recipes/libsdl/libsdl-image_1.2.6.bb
+++ b/recipes/libsdl/libsdl-image_1.2.6.bb
@@ -1,5 +1,6 @@
require libsdl-image.inc
-PR = "r1"
+
+PR = "${INC_PR}.1"
DEPENDS += "tiff"