aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libsdl
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2009-11-18 09:15:36 +0000
committerGraeme Gregory <dp@xora.org.uk>2009-11-18 09:15:36 +0000
commit7f3d2b172af63fc894f80eece075434b2c5fbbc5 (patch)
tree0ed47be57dbb8fcd199a9b82858ec730840e72c2 /recipes/libsdl
parent5f13a271b010da627fc8b411182fbc58c03aec23 (diff)
downloadopenembedded-7f3d2b172af63fc894f80eece075434b2c5fbbc5.tar.gz
libsdl-mixer_1.2.11.bb : update the latest version
Diffstat (limited to 'recipes/libsdl')
-rw-r--r--recipes/libsdl/libsdl-mixer_1.2.11.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/libsdl/libsdl-mixer_1.2.11.bb b/recipes/libsdl/libsdl-mixer_1.2.11.bb
new file mode 100644
index 0000000000..5ecd2944a2
--- /dev/null
+++ b/recipes/libsdl/libsdl-mixer_1.2.11.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Simple DirectMedia Layer mixer library."
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "virtual/libsdl libmikmod libvorbis"
+LICENSE = "LGPL"
+
+SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz"
+S = "${WORKDIR}/SDL_mixer-${PV}"
+
+export SDL_CONFIG = "${STAGING_BINDIR_CROSS}/sdl-config"
+
+inherit autotools_stage
+
+EXTRA_OECONF = "--disable-music-mp3"
+# although we build smpeg... need to find out how
+# to deal with optional dependencies
+
+do_compile() {
+ # Override SDL_LIBS to include a linker rpath so the linker
+ # can find the correct libdl.so when it links playwave to
+ # libSDL_mixer.so.
+ oe_runmake SDL_LIBS="$(pkg-config sdl --libs) -Wl,-rpath-link,${STAGING_LIBDIR}"
+}