aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libshout
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libshout
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libshout')
-rw-r--r--recipes/libshout/files/no-host-includes.ac13
-rw-r--r--recipes/libshout/libshout.inc20
-rw-r--r--recipes/libshout/libshout_2.2.2.bb1
3 files changed, 34 insertions, 0 deletions
diff --git a/recipes/libshout/files/no-host-includes.ac b/recipes/libshout/files/no-host-includes.ac
new file mode 100644
index 0000000000..f5255359b0
--- /dev/null
+++ b/recipes/libshout/files/no-host-includes.ac
@@ -0,0 +1,13 @@
+diff --git a/configure.ac b/configure.ac
+index 52fc51d..e93fc52 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -179,7 +179,7 @@ eval shout_includedir="$includedir"
+ prefix="$save_prefix"
+
+ SHOUT_VERSION="$VERSION"
+-SHOUT_CPPFLAGS="-I$shout_includedir $VORBIS_CFLAGS $PTHREAD_CPPFLAGS"
++SHOUT_CPPFLAGS="$VORBIS_CFLAGS $PTHREAD_CPPFLAGS"
+ SHOUT_CFLAGS="$PTHREAD_CFLAGS"
+ SHOUT_LIBS="-lshout"
+
diff --git a/recipes/libshout/libshout.inc b/recipes/libshout/libshout.inc
new file mode 100644
index 0000000000..3037eb0f46
--- /dev/null
+++ b/recipes/libshout/libshout.inc
@@ -0,0 +1,20 @@
+DESCRIPTION = "Library which can be used to write a source client like ices"
+HOMEPAGE = "http://www.icecast.org"
+DEPENDS = "speex libtheora libvorbis libogg"
+LICENSE = "LGPL"
+
+SRC_URI = "http://downloads.us.xiph.org/releases/libshout/libshout-${PV}.tar.gz \
+ file://no-host-includes.ac;patch=1 "
+
+inherit autotools
+
+do_configure_prepend() {
+ # Use the staged m4 files
+ rm -f ${S}/m4/speex.m4
+ rm -f ${S}/m4/ogg.m4
+ rm -f ${S}/m4/vorbis.m4
+}
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/libshout/libshout_2.2.2.bb b/recipes/libshout/libshout_2.2.2.bb
new file mode 100644
index 0000000000..bd54419686
--- /dev/null
+++ b/recipes/libshout/libshout_2.2.2.bb
@@ -0,0 +1 @@
+require ${PN}.inc