summaryrefslogtreecommitdiffstats
path: root/recipes/libsigc++-1.2
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libsigc++-1.2
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libsigc++-1.2')
-rw-r--r--recipes/libsigc++-1.2/libsigc++-1.2-1.2.5/autofoo.patch125
-rw-r--r--recipes/libsigc++-1.2/libsigc++-1.2-1.2.5/pkgconfig.patch13
-rw-r--r--recipes/libsigc++-1.2/libsigc++-1.2-1.2.7/autofoo.patch126
-rw-r--r--recipes/libsigc++-1.2/libsigc++-1.2-1.2.7/disable-tests.patch13
-rw-r--r--recipes/libsigc++-1.2/libsigc++-1.2_1.2.5.bb28
-rw-r--r--recipes/libsigc++-1.2/libsigc++-1.2_1.2.7.bb30
6 files changed, 335 insertions, 0 deletions
diff --git a/recipes/libsigc++-1.2/libsigc++-1.2-1.2.5/autofoo.patch b/recipes/libsigc++-1.2/libsigc++-1.2-1.2.5/autofoo.patch
new file mode 100644
index 0000000000..9eb2b874a7
--- /dev/null
+++ b/recipes/libsigc++-1.2/libsigc++-1.2-1.2.5/autofoo.patch
@@ -0,0 +1,125 @@
+--- libsigc++-1.2.5-old/configure.in 2003-05-14 10:04:25.000000000 +0200
++++ libsigc++-1.2.5/configure.in 2004-07-03 10:00:13.000000000 +0200
+@@ -35,9 +35,9 @@
+ dnl AC_SUBST(SIGC_RELEASE, $SIGC_RELEASE)
+ AC_SUBST(SIGC_VERSION)
+
+-AC_DEFINE_UNQUOTED(SIGC_MAJOR_VERSION, $SIGC_MAJOR_VERSION)
+-AC_DEFINE_UNQUOTED(SIGC_MINOR_VERSION, $SIGC_MINOR_VERSION)
+-AC_DEFINE_UNQUOTED(SIGC_MICRO_VERSION, $SIGC_MICRO_VERSION)
++AC_DEFINE_UNQUOTED(SIGC_MAJOR_VERSION, $SIGC_MAJOR_VERSION, [library major version])
++AC_DEFINE_UNQUOTED(SIGC_MINOR_VERSION, $SIGC_MINOR_VERSION, [library minor version])
++AC_DEFINE_UNQUOTED(SIGC_MICRO_VERSION, $SIGC_MICRO_VERSION, [library micro version])
+
+ AC_CONFIG_AUX_DIR(scripts)
+
+@@ -50,6 +50,23 @@
+
+ dnl Specify a configuration file
+ AM_CONFIG_HEADER(sigc++/config/sigcconfig.h)
++AH_BOTTOM([
++// Window DLL declarations
++
++#ifdef LIBSIGC_DLL
++ #if defined(LIBSIGC_COMPILATION) && defined(DLL_EXPORT)
++ #define LIBSIGC_API __declspec(dllexport)
++ #define LIBSIGC_TMPL
++ #elif !defined(LIBSIGC_COMPILATION)
++ #define LIBSIGC_API __declspec(dllimport)
++ #define LIBSIGC_TMPL extern
++ #else
++ #define LIBSIGC_API
++ #endif /* LIBSIGC_COMPILATION - DLL_EXPORT */
++#else
++ #define LIBSIGC_API
++#endif /* LIBSIGC_DLL */
++])
+
+ AM_MAINTAINER_MODE
+
+@@ -288,10 +307,10 @@
+ };
+ ],[
+ ],
+- AC_DEFINE(SIGC_CXX_EXPLICIT,explicit)
++ AC_DEFINE(SIGC_CXX_EXPLICIT,explicit,[if C++ compiler supports explicit])
+ ac_cxx_explicit=yes
+ ,
+- AC_DEFINE(SIGC_CXX_EXPLICIT,)
++ AC_DEFINE(SIGC_CXX_EXPLICIT)
+ ac_cxx_explicit=no
+ )
+ AC_MSG_RESULT([$ac_cxx_explicit])
+@@ -305,7 +324,7 @@
+ };
+ ],[
+ ],
+- AC_DEFINE(SIGC_CXX_EXPLICIT_COPY,explicit)
++ AC_DEFINE(SIGC_CXX_EXPLICIT_COPY,explicit,[if C++ compiler supports explicit copy ctor])
+ ac_cxx_explicit_copy_ctor=yes
+ ,
+ AC_DEFINE(SIGC_CXX_EXPLICIT_COPY,)
+@@ -413,7 +432,7 @@
+ k<void,void> a;
+ ],[
+ ac_cxx_partial_specialization=yes
+- AC_DEFINE(SIGC_CXX_PARTIAL_SPEC)
++ AC_DEFINE(SIGC_CXX_PARTIAL_SPEC,,[if C++ compiler supports partial specialization])
+ ],[
+ # config_error=yes
+ ac_cxx_partial_specialization=no
+@@ -434,7 +453,7 @@
+ ],[
+ ac_cxx_namespaces=yes
+ AC_MSG_RESULT([$ac_cxx_namespaces])
+- AC_DEFINE(SIGC_CXX_NAMESPACES)
++ AC_DEFINE(SIGC_CXX_NAMESPACES,,[if C++ compiler supports name spaces])
+ ],[
+ ac_cxx_namespaces=no
+ AC_MSG_RESULT([$ac_cxx_namespaces])
+@@ -474,7 +493,7 @@
+ A<int> i;
+ ],[
+ ],[
+- AC_DEFINE(SIGC_CXX_INT_CTOR)
++ AC_DEFINE(SIGC_CXX_INT_CTOR,,[if C++ compiler has intrinsic constructors])
+ ac_cxx_tmpl_intctor=yes
+ ],[
+ ac_cxx_tmpl_intctor=no
+@@ -515,7 +534,7 @@
+ ],[
+ ],[
+ ac_cxx_void_return=yes
+- AC_DEFINE(SIGC_CXX_VOID_RETURN)
++ AC_DEFINE(SIGC_CXX_VOID_RETURN,,[if C++ compiler allows void returns])
+ ],[
+ ac_cxx_void_return=no
+ ])
+@@ -530,7 +549,7 @@
+ ],[
+ ],[
+ ac_cxx_void_cast_return=yes
+- AC_DEFINE(SIGC_CXX_VOID_CAST_RETURN)
++ AC_DEFINE(SIGC_CXX_VOID_CAST_RETURN,,[if C++ compiler supports void cast return])
+ ],[
+ ac_cxx_void_cast_return=no
+ ])
+@@ -565,7 +584,7 @@
+ P<int&>::ptr q=b;
+ ],[
+ ac_cxx_specialize_references=yes
+- AC_DEFINE(SIGC_CXX_SPECIALIZE_REFERENCES)
++ AC_DEFINE(SIGC_CXX_SPECIALIZE_REFERENCES,,[if C++ compiler allows specialization of references])
+ ],[
+ ac_cxx_specialize_references=no
+ ])
+--- libsigc++-1.2.5-old/Makefile.am 2004-06-27 12:45:19.000000000 +0200
++++ libsigc++-1.2.5/Makefile.am 2004-07-03 08:40:44.000000000 +0200
+@@ -1,6 +1,6 @@
+ SUBDIRS = sigc++ tests doc
+ DIST_SUBDIRS = $(SUBDIRS) examples scripts MSVC_6 MSVC_Net2003
+-ACLOCAL_AMFLAGS = -I $(srcdir)/scripts
++ACLOCAL_AMFLAGS = -I ./scripts
+
+ EXTRA_DIST = \
+ FEATURES IDEAS \
diff --git a/recipes/libsigc++-1.2/libsigc++-1.2-1.2.5/pkgconfig.patch b/recipes/libsigc++-1.2/libsigc++-1.2-1.2.5/pkgconfig.patch
new file mode 100644
index 0000000000..7495a4d34e
--- /dev/null
+++ b/recipes/libsigc++-1.2/libsigc++-1.2-1.2.5/pkgconfig.patch
@@ -0,0 +1,13 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- libsigc++-1.2.5/sigc++-1.2.pc.in~pkgconfig
++++ libsigc++-1.2.5/sigc++-1.2.pc.in
+@@ -7,4 +7,4 @@
+ Description: Type-safe signal and callback system for C++
+ Version: @VERSION@
+ Libs: -L${libdir} -lsigc-1.2
+-Cflags: -I${exec_prefix}/lib/sigc++-1.2/include -I${includedir}/sigc++-1.2
++Cflags: -I${libdir}/sigc++-1.2/include -I${includedir}/sigc++-1.2
diff --git a/recipes/libsigc++-1.2/libsigc++-1.2-1.2.7/autofoo.patch b/recipes/libsigc++-1.2/libsigc++-1.2-1.2.7/autofoo.patch
new file mode 100644
index 0000000000..a5f7063af7
--- /dev/null
+++ b/recipes/libsigc++-1.2/libsigc++-1.2-1.2.7/autofoo.patch
@@ -0,0 +1,126 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- libsigc++-1.2.7/configure.in~autofoo.patch
++++ libsigc++-1.2.7/configure.in
+@@ -35,9 +35,9 @@
+ dnl AC_SUBST(SIGC_RELEASE, $SIGC_RELEASE)
+ AC_SUBST(SIGC_VERSION)
+
+-AC_DEFINE_UNQUOTED(SIGC_MAJOR_VERSION, $SIGC_MAJOR_VERSION)
+-AC_DEFINE_UNQUOTED(SIGC_MINOR_VERSION, $SIGC_MINOR_VERSION)
+-AC_DEFINE_UNQUOTED(SIGC_MICRO_VERSION, $SIGC_MICRO_VERSION)
++AC_DEFINE_UNQUOTED(SIGC_MAJOR_VERSION, $SIGC_MAJOR_VERSION, [library major version])
++AC_DEFINE_UNQUOTED(SIGC_MINOR_VERSION, $SIGC_MINOR_VERSION, [library minor version])
++AC_DEFINE_UNQUOTED(SIGC_MICRO_VERSION, $SIGC_MICRO_VERSION, [library micro version])
+
+ AC_CONFIG_AUX_DIR(scripts)
+
+@@ -50,7 +50,23 @@
+
+ dnl Specify a configuration file
+ AM_CONFIG_HEADER(sigc++/config/sigcconfig.h)
++AH_BOTTOM([
++// Window DLL declarations
+
++#ifdef LIBSIGC_DLL
++ #if defined(LIBSIGC_COMPILATION) && defined(DLL_EXPORT)
++ #define LIBSIGC_API __declspec(dllexport)
++ #define LIBSIGC_TMPL
++ #elif !defined(LIBSIGC_COMPILATION)
++ #define LIBSIGC_API __declspec(dllimport)
++ #define LIBSIGC_TMPL extern
++ #else
++ #define LIBSIGC_API
++ #endif /* LIBSIGC_COMPILATION - DLL_EXPORT */
++#else
++ #define LIBSIGC_API
++#endif /* LIBSIGC_DLL */
++])
+ AM_MAINTAINER_MODE
+
+ # echo $USE_MAINTAINER_MODE
+@@ -288,7 +304,7 @@
+ };
+ ],[
+ ],
+- AC_DEFINE(SIGC_CXX_EXPLICIT,explicit)
++ AC_DEFINE(SIGC_CXX_EXPLICIT,explicit,[if C++ compiler supports explicit])
+ ac_cxx_explicit=yes
+ ,
+ AC_DEFINE(SIGC_CXX_EXPLICIT,)
+@@ -305,7 +321,7 @@
+ };
+ ],[
+ ],
+- AC_DEFINE(SIGC_CXX_EXPLICIT_COPY,explicit)
++ AC_DEFINE(SIGC_CXX_EXPLICIT_COPY,explicit,[if C++ compiler supports explicit copy ctor])
+ ac_cxx_explicit_copy_ctor=yes
+ ,
+ AC_DEFINE(SIGC_CXX_EXPLICIT_COPY,)
+@@ -413,7 +429,7 @@
+ k<void,void> a;
+ ],[
+ ac_cxx_partial_specialization=yes
+- AC_DEFINE(SIGC_CXX_PARTIAL_SPEC)
++ AC_DEFINE(SIGC_CXX_PARTIAL_SPEC,[if C++ compiler supports partial specialization])
+ ],[
+ # config_error=yes
+ ac_cxx_partial_specialization=no
+@@ -434,7 +450,7 @@
+ ],[
+ ac_cxx_namespaces=yes
+ AC_MSG_RESULT([$ac_cxx_namespaces])
+- AC_DEFINE(SIGC_CXX_NAMESPACES)
++ AC_DEFINE(SIGC_CXX_NAMESPACES,,[if C++ compiler supports name spaces])
+ ],[
+ ac_cxx_namespaces=no
+ AC_MSG_RESULT([$ac_cxx_namespaces])
+@@ -474,7 +490,7 @@
+ A<int> i;
+ ],[
+ ],[
+- AC_DEFINE(SIGC_CXX_INT_CTOR)
++ AC_DEFINE(SIGC_CXX_INT_CTOR,,[if C++ compiler has intrinsic constructors])
+ ac_cxx_tmpl_intctor=yes
+ ],[
+ ac_cxx_tmpl_intctor=no
+@@ -515,7 +531,7 @@
+ ],[
+ ],[
+ ac_cxx_void_return=yes
+- AC_DEFINE(SIGC_CXX_VOID_RETURN)
++ AC_DEFINE(SIGC_CXX_VOID_RETURN,,[if C++ compiler allows void returns])
+ ],[
+ ac_cxx_void_return=no
+ ])
+@@ -530,7 +546,7 @@
+ ],[
+ ],[
+ ac_cxx_void_cast_return=yes
+- AC_DEFINE(SIGC_CXX_VOID_CAST_RETURN)
++ AC_DEFINE(SIGC_CXX_VOID_CAST_RETURN,,[if C++ compiler supports void cast return])
+ ],[
+ ac_cxx_void_cast_return=no
+ ])
+@@ -565,7 +581,7 @@
+ P<int&>::ptr q=b;
+ ],[
+ ac_cxx_specialize_references=yes
+- AC_DEFINE(SIGC_CXX_SPECIALIZE_REFERENCES)
++ AC_DEFINE(SIGC_CXX_SPECIALIZE_REFERENCES,,[if C++ compiler allows specialization of references])
+ ],[
+ ac_cxx_specialize_references=no
+ ])
+--- libsigc++-1.2.7/Makefile.am~autofoo.patch
++++ libsigc++-1.2.7/Makefile.am
+@@ -1,6 +1,6 @@
+ SUBDIRS = sigc++ tests doc MSVC_6 MSVC_Net2003 eVC4
+ DIST_SUBDIRS = $(SUBDIRS) examples scripts
+-ACLOCAL_AMFLAGS = -I $(srcdir)/scripts
++ACLOCAL_AMFLAGS = -I ./scripts
+
+ EXTRA_DIST = \
+ FEATURES IDEAS \
diff --git a/recipes/libsigc++-1.2/libsigc++-1.2-1.2.7/disable-tests.patch b/recipes/libsigc++-1.2/libsigc++-1.2-1.2.7/disable-tests.patch
new file mode 100644
index 0000000000..92145a4ec9
--- /dev/null
+++ b/recipes/libsigc++-1.2/libsigc++-1.2-1.2.7/disable-tests.patch
@@ -0,0 +1,13 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- libsigc++-1.2.7/Makefile.am~disable-tests
++++ libsigc++-1.2.7/Makefile.am
+@@ -1,4 +1,4 @@
+-SUBDIRS = sigc++ tests doc MSVC_6 MSVC_Net2003 eVC4
++SUBDIRS = sigc++
+ DIST_SUBDIRS = $(SUBDIRS) examples scripts
+ ACLOCAL_AMFLAGS = -I ./scripts
+
diff --git a/recipes/libsigc++-1.2/libsigc++-1.2_1.2.5.bb b/recipes/libsigc++-1.2/libsigc++-1.2_1.2.5.bb
new file mode 100644
index 0000000000..072492da80
--- /dev/null
+++ b/recipes/libsigc++-1.2/libsigc++-1.2_1.2.5.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "A library for loose coupling of C++ method calls"
+SECTION = "libs"
+PRIORITY = "optional"
+PR = "r1"
+LICENSE = "GPL LGPL"
+SRC_URI = "${SOURCEFORGE_MIRROR}/libsigc/libsigc++-${PV}.tar.gz \
+ file://autofoo.patch;patch=1 \
+ file://pkgconfig.patch;patch=1"
+S = "${WORKDIR}/libsigc++-${PV}"
+
+inherit autotools pkgconfig
+
+FILES_${PN}-dev += "${libdir}/sigc++-*/"
+
+acpaths = ""
+
+do_stage() {
+ install -d ${STAGING_LIBDIR}/sigc++-1.2/include
+ install -m 0644 sigc++/config/sigcconfig.h ${STAGING_LIBDIR}/sigc++-1.2/include/
+ oe_libinstall -so -C sigc++ libsigc-1.2 ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/sigc++-1.2/sigc++
+ for f in sigc++/*.h
+ do
+ install -m 0644 $f ${STAGING_INCDIR}/sigc++-1.2/sigc++/
+ done
+}
+
diff --git a/recipes/libsigc++-1.2/libsigc++-1.2_1.2.7.bb b/recipes/libsigc++-1.2/libsigc++-1.2_1.2.7.bb
new file mode 100644
index 0000000000..75e830fd2b
--- /dev/null
+++ b/recipes/libsigc++-1.2/libsigc++-1.2_1.2.7.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "A library for loose coupling of C++ method calls"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL LGPL"
+PR = "r0"
+
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/libsigc++/1.2/libsigc++-${PV}.tar.bz2 \
+ file://autofoo.patch;patch=1 \
+ file://disable-tests.patch;patch=1"
+S = "${WORKDIR}/libsigc++-${PV}"
+
+inherit autotools pkgconfig
+
+# FIXME: Check why tests don't compile
+
+acpaths = ""
+
+do_stage() {
+ install -d ${STAGING_LIBDIR}/sigc++-1.2/include
+ install -m 0644 sigc++/config/sigcconfig.h ${STAGING_LIBDIR}/sigc++-1.2/include/
+ oe_libinstall -so -C sigc++ libsigc-1.2 ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/sigc++-1.2/sigc++
+ for f in sigc++/*.h
+ do
+ install -m 0644 $f ${STAGING_INCDIR}/sigc++-1.2/sigc++/
+ done
+}
+
+FILES_${PN}-dev += "${libdir}/sigc++-*/"