aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libsigcx/libsigcx0_0.6.4.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libsigcx/libsigcx0_0.6.4.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libsigcx/libsigcx0_0.6.4.bb')
-rw-r--r--recipes/libsigcx/libsigcx0_0.6.4.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/libsigcx/libsigcx0_0.6.4.bb b/recipes/libsigcx/libsigcx0_0.6.4.bb
new file mode 100644
index 0000000000..1f070fc1d7
--- /dev/null
+++ b/recipes/libsigcx/libsigcx0_0.6.4.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "Additional features for libsigc++, with a focus on multi-threading."
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "libsigc++-1.2"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/libsigcx/libsigcx-${PV}.tar.gz \
+ file://libsigcx-0.6.4-add-missing-autogen-sh-swb.patch;patch=1 \
+ file://libsigcx-0.6.4-build-swb.patch;patch=1 \
+ file://libsigcx-0.6.4-fix-ac-try-run-swb.patch;patch=1 \
+ file://libsigcx-200505061-fix-dist-swb.patch;patch=1 \
+ file://libsigcx-0.6.4-pack-predeclare-swb.patch;patch=1 \
+ file://autotool-regen.patch;patch=1"
+S = "${WORKDIR}/libsigcx-${PV}"
+
+inherit autotools pkgconfig
+
+acpaths = ""
+
+do_stage() {
+ install -d ${STAGING_LIBDIR}/sigcx-0.6/include
+ install -m 0644 sigcxconfig.h ${STAGING_LIBDIR}/sigcx-0.6/include/sigcxconfig.h
+ oe_libinstall -so -C sigcx libsigcx-0.6 ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/sigcx-0.6/sigcx
+ for f in sigcx/*.h
+ do
+ install -m 0644 $f ${STAGING_INCDIR}/sigcx-0.6/sigcx/
+ done
+}
+
+FILES_${PN}-dev += "${libdir}/sigcx-*/"
+