aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libssh
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-04-07 09:56:17 +0200
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-04-07 10:41:47 +0200
commit6c5e86faf07d37d5e85c4249e3bb52555e9d839b (patch)
tree3834c011fb0bac424bb349aecb7e261407de4c46 /recipes/libssh
parentfbf22c52a21c8f423d8c6683155be9248f21b31a (diff)
downloadopenembedded-6c5e86faf07d37d5e85c4249e3bb52555e9d839b.tar.gz
libssh: add libssh-native
Diffstat (limited to 'recipes/libssh')
-rw-r--r--recipes/libssh/libssh-native_0.2.bb4
-rw-r--r--recipes/libssh/libssh_0.11.bb35
-rw-r--r--recipes/libssh/libssh_0.2.bb13
3 files changed, 11 insertions, 41 deletions
diff --git a/recipes/libssh/libssh-native_0.2.bb b/recipes/libssh/libssh-native_0.2.bb
new file mode 100644
index 0000000000..289161d329
--- /dev/null
+++ b/recipes/libssh/libssh-native_0.2.bb
@@ -0,0 +1,4 @@
+require libssh_${PV}.bb
+inherit native
+DEPENDS = ""
+
diff --git a/recipes/libssh/libssh_0.11.bb b/recipes/libssh/libssh_0.11.bb
deleted file mode 100644
index 833567ebb0..0000000000
--- a/recipes/libssh/libssh_0.11.bb
+++ /dev/null
@@ -1,35 +0,0 @@
-SECTION = "libs"
-DESCRIPTION = "The SSH library is a C library to authenticate in a \
-simple manner to one or more SSH servers. The goal of this project \
-is to provide a library much simpler to use than OpenSSHs one. It \
-includes SFTP support, and a sample SSH client is provided."
-DEPENDS = "openssl"
-LICENSE = "LGPL"
-
-DEFAULT_PREFERENCE="-1"
-
-SRC_URI = "http://www.0xbadc0de.be/libssh/libssh-${PV}.tgz"
-
-inherit autotools
-
-EXTRA_OECONF = "--cache-file=${S}/config.cache"
-
-do_stage () {
- set -x
- install -d ${STAGING_INCDIR}/libssh
- for i in crypto.h libssh.h sftp.h ssh2.h; do
- install -m 0644 ${S}/include/libssh/$i ${STAGING_INCDIR}/libssh/
- done
- oe_libinstall -so -C libssh libssh ${STAGING_LIBDIR}
-}
-
-do_install () {
- oe_runmake "prefix=${D}${prefix}" \
- "exec_prefix=${D}${exec_prefix}" \
- "bindir=${D}${bindir}" \
- "incldir=${D}${includedir}" \
- "infodir=${D}${infodir}" \
- "mandir=${D}${mandir}/man1" \
- "libdir=${D}${libdir}" \
- install
-}
diff --git a/recipes/libssh/libssh_0.2.bb b/recipes/libssh/libssh_0.2.bb
index b776094018..fb0c4c300c 100644
--- a/recipes/libssh/libssh_0.2.bb
+++ b/recipes/libssh/libssh_0.2.bb
@@ -1,24 +1,25 @@
-# Released under the MIT license (see COPYING.MIT for the terms)
-
DESCRIPTION = "The SSH library is a C library to authenticate in a \
simple manner to one or more SSH servers. The goal of this project \
is to provide a library much simpler to use than OpenSSHs one. It \
includes SFTP support, and a sample SSH client is provided."
-
HOMEPAGE = "http://0xbadc0de.be/wiki/libssh:libssh"
LICENSE = "LGPL"
SECTION = "libs"
DEPENDS = "openssl"
-SRC_URI = "http://www.0xbadc0de.be/libssh/libssh-${PV}.tgz \
- file://libssh_libdir_fix.patch;patch=1 \
- "
+
+SRC_URI = "\
+ http://www.0xbadc0de.be/libssh/libssh-${PV}.tgz \
+ file://libssh_libdir_fix.patch;patch=1 \
+"
inherit autotools
EXTRA_OECONF = "--cache-file=${S}/config.cache"
+
do_compile () {
oenote make "$@"
make "$@" || die "oe_runmake failed"
}
+
do_stage () {
install -d ${STAGING_INCDIR}/libssh
for i in crypto.h libssh.h sftp.h ssh2.h; do