summaryrefslogtreecommitdiffstats
path: root/recipes/libssh
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libssh
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libssh')
-rw-r--r--recipes/libssh/files/libssh_libdir_fix.patch13
-rw-r--r--recipes/libssh/libssh_0.11.bb35
-rw-r--r--recipes/libssh/libssh_0.2.bb28
3 files changed, 76 insertions, 0 deletions
diff --git a/recipes/libssh/files/libssh_libdir_fix.patch b/recipes/libssh/files/libssh_libdir_fix.patch
new file mode 100644
index 0000000000..a9fcce79e3
--- /dev/null
+++ b/recipes/libssh/files/libssh_libdir_fix.patch
@@ -0,0 +1,13 @@
+diff -NurpP --minimal libssh-0.2/libssh/Makefile.in libssh-0.2-libdir/libssh/Makefile.in
+--- libssh-0.2/libssh/Makefile.in 2006-12-29 23:03:59.000000000 +0800
++++ libssh-0.2-libdir/libssh/Makefile.in 2008-10-13 10:04:13.000000000 +0800
+@@ -15,7 +15,7 @@ exec_prefix = @exec_prefix@
+ bindir = $(exec_prefix)/bin
+ incldir= $(prefix)/include
+ infodir = $(prefix)/info
+-libdir = $(prefix)/lib/
++libdir = $(prefix)/lib
+ mandir = $(prefix)/man/man1
+
+ CC = @CC@
+
diff --git a/recipes/libssh/libssh_0.11.bb b/recipes/libssh/libssh_0.11.bb
new file mode 100644
index 0000000000..833567ebb0
--- /dev/null
+++ b/recipes/libssh/libssh_0.11.bb
@@ -0,0 +1,35 @@
+SECTION = "libs"
+DESCRIPTION = "The SSH library is a C library to authenticate in a \
+simple manner to one or more SSH servers. The goal of this project \
+is to provide a library much simpler to use than OpenSSHs one. It \
+includes SFTP support, and a sample SSH client is provided."
+DEPENDS = "openssl"
+LICENSE = "LGPL"
+
+DEFAULT_PREFERENCE="-1"
+
+SRC_URI = "http://www.0xbadc0de.be/libssh/libssh-${PV}.tgz"
+
+inherit autotools
+
+EXTRA_OECONF = "--cache-file=${S}/config.cache"
+
+do_stage () {
+ set -x
+ install -d ${STAGING_INCDIR}/libssh
+ for i in crypto.h libssh.h sftp.h ssh2.h; do
+ install -m 0644 ${S}/include/libssh/$i ${STAGING_INCDIR}/libssh/
+ done
+ oe_libinstall -so -C libssh libssh ${STAGING_LIBDIR}
+}
+
+do_install () {
+ oe_runmake "prefix=${D}${prefix}" \
+ "exec_prefix=${D}${exec_prefix}" \
+ "bindir=${D}${bindir}" \
+ "incldir=${D}${includedir}" \
+ "infodir=${D}${infodir}" \
+ "mandir=${D}${mandir}/man1" \
+ "libdir=${D}${libdir}" \
+ install
+}
diff --git a/recipes/libssh/libssh_0.2.bb b/recipes/libssh/libssh_0.2.bb
new file mode 100644
index 0000000000..b776094018
--- /dev/null
+++ b/recipes/libssh/libssh_0.2.bb
@@ -0,0 +1,28 @@
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+DESCRIPTION = "The SSH library is a C library to authenticate in a \
+simple manner to one or more SSH servers. The goal of this project \
+is to provide a library much simpler to use than OpenSSHs one. It \
+includes SFTP support, and a sample SSH client is provided."
+
+HOMEPAGE = "http://0xbadc0de.be/wiki/libssh:libssh"
+LICENSE = "LGPL"
+SECTION = "libs"
+DEPENDS = "openssl"
+SRC_URI = "http://www.0xbadc0de.be/libssh/libssh-${PV}.tgz \
+ file://libssh_libdir_fix.patch;patch=1 \
+ "
+inherit autotools
+
+EXTRA_OECONF = "--cache-file=${S}/config.cache"
+do_compile () {
+ oenote make "$@"
+ make "$@" || die "oe_runmake failed"
+}
+do_stage () {
+ install -d ${STAGING_INCDIR}/libssh
+ for i in crypto.h libssh.h sftp.h ssh2.h; do
+ install -m 0644 ${S}/include/libssh/$i ${STAGING_INCDIR}/libssh/
+ done
+ oe_libinstall -so -C libssh libssh ${STAGING_LIBDIR}
+}