aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libtiff
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-02-17 15:37:53 -0700
committerSteffen Sledz <sledz@dresearch.de>2011-02-25 08:48:39 +0100
commit4cdc46ac34cf4374f20bf4eb950380377ffb95f5 (patch)
treeb0c221fb7dbc3e3243975551ea67f6cf7744a1e1 /recipes/libtiff
parenta76f7cd1d881f0e596452b036a30e4345929d478 (diff)
downloadopenembedded-4cdc46ac34cf4374f20bf4eb950380377ffb95f5.tar.gz
tiff: Fix RPATH QA issues
Based on the fix for 'acl' Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/libtiff')
-rw-r--r--recipes/libtiff/tiff_3.9.4.bb10
1 files changed, 8 insertions, 2 deletions
diff --git a/recipes/libtiff/tiff_3.9.4.bb b/recipes/libtiff/tiff_3.9.4.bb
index f54a19b405..b64b72e5ee 100644
--- a/recipes/libtiff/tiff_3.9.4.bb
+++ b/recipes/libtiff/tiff_3.9.4.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "http://www.remotesensing.org/libtiff/"
DEPENDS = "zlib jpeg lzo"
PV = "3.9.4+4.0.0beta6"
-PR = "r0"
+PR = "r1"
SRC_URI = "http://download.osgeo.org/libtiff/tiff-4.0.0beta6.tar.gz \
file://tiff-lp589145.diff;striplevel=0 \
@@ -16,7 +16,13 @@ S = "${WORKDIR}/tiff-4.0.0beta6"
inherit autotools
-EXTRA_OECONF = "--without-x"
+EXTRA_OECONF = "--without-x --disable-rpath"
+
+do_configure_append() {
+ # Fix RPATH issues.
+ sed -i ${S}/config.status -e s,^\\\(hardcode_into_libs=\\\).*$,\\1\'no\',
+ ${S}/config.status
+}
PACKAGES =+ "tiffxx tiffxx-dbg tiffxx-dev tiff-utils tiff-utils-dbg"
FILES_tiffxx = "${libdir}/libtiffxx.so.*"