aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libtiff
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libtiff
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libtiff')
-rw-r--r--recipes/libtiff/tiff-3.7.2/configure.patch20
-rw-r--r--recipes/libtiff/tiff_3.7.2.bb25
-rw-r--r--recipes/libtiff/tiff_3.8.2.bb17
3 files changed, 62 insertions, 0 deletions
diff --git a/recipes/libtiff/tiff-3.7.2/configure.patch b/recipes/libtiff/tiff-3.7.2/configure.patch
new file mode 100644
index 0000000000..599af6c188
--- /dev/null
+++ b/recipes/libtiff/tiff-3.7.2/configure.patch
@@ -0,0 +1,20 @@
+Index: tiff-3.7.2/configure.ac
+===================================================================
+--- tiff-3.7.2.orig/configure.ac 2005-03-15 10:42:19.000000000 -0500
++++ tiff-3.7.2/configure.ac 2007-10-10 12:05:58.000000000 -0400
+@@ -32,7 +32,6 @@
+ AC_CANONICAL_TARGET
+
+ AM_INIT_AUTOMAKE
+-AM_PROG_CC_C_O
+ dnl Do not rebuild generated files every time
+ AM_MAINTAINER_MODE
+
+@@ -55,6 +54,7 @@
+
+ dnl Checks for programs.
+ AC_PROG_CC
++AM_PROG_CC_C_O
+
+ dnl We want warnings. As many warnings as possible.
+ #VL_PROG_CC_WARNINGS()
diff --git a/recipes/libtiff/tiff_3.7.2.bb b/recipes/libtiff/tiff_3.7.2.bb
new file mode 100644
index 0000000000..1f28e718bc
--- /dev/null
+++ b/recipes/libtiff/tiff_3.7.2.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "This software provides support for the Tag Image File Format (TIFF)"
+LICENSE = ""
+HOMEPAGE = "http://www.remotesensing.org/libtiff/"
+DEPENDS = "zlib jpeg lzo"
+PR = "r4"
+
+SRC_URI = "http://dl.maptools.org/dl/libtiff/old/tiff-${PV}.tar.gz \
+ file://configure.patch;patch=1"
+
+inherit autotools
+
+do_stage() {
+ autotools_stage_includes
+ install -d ${STAGING_LIBDIR}
+ oe_libinstall -C libtiff -a -so libtiff ${STAGING_LIBDIR}
+ oe_libinstall -C libtiff -a -so libtiffxx ${STAGING_LIBDIR}
+
+}
+
+PACKAGES =+ "tiffxx tiffxx-dbg tiffxx-dev tiff-utils tiff-utils-dbg"
+FILES_tiffxx = "${libdir}/libtiffxx.so.*"
+FILES_tiffxx-dev = "${libdir}/libtiffxx.so ${libdir}/libtiffxx.*a"
+FILES_tiffxx-dbg += "${libdir}/.debug/libtiffxx.so*"
+FILES_tiff-utils = "${bindir}/*"
+FILES_tiff-utils-dbg += "${bindir}/.debug/"
diff --git a/recipes/libtiff/tiff_3.8.2.bb b/recipes/libtiff/tiff_3.8.2.bb
new file mode 100644
index 0000000000..00edb40eb3
--- /dev/null
+++ b/recipes/libtiff/tiff_3.8.2.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "This software provides support for the Tag Image File Format (TIFF)"
+LICENSE = "${PN}"
+HOMEPAGE = "http://www.remotesensing.org/libtiff/"
+DEPENDS = "zlib jpeg lzo"
+PV = "3.8.2+4.0.0beta2"
+
+SRC_URI = "ftp://ftp.remotesensing.org/pub/libtiff/tiff-4.0.0beta2.tar.gz"
+S = "${WORKDIR}/${PN}-4.0.0beta2"
+
+inherit autotools_stage
+
+PACKAGES =+ "tiffxx tiffxx-dbg tiffxx-dev tiff-utils tiff-utils-dbg"
+FILES_tiffxx = "${libdir}/libtiffxx.so.*"
+FILES_tiffxx-dev = "${libdir}/libtiffxx.so ${libdir}/libtiffxx.*a"
+FILES_tiffxx-dbg += "${libdir}/.debug/libtiffxx.so*"
+FILES_tiff-utils = "${bindir}/*"
+FILES_tiff-utils-dbg += "${bindir}/.debug/"