aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libtool/libtool_2.2.6a.bb
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2009-07-27 18:51:22 +0000
committerutx@penguin.cz <utx@penguin.cz>2009-07-27 18:51:22 +0000
commit2e0fa4918d643ce6ec0299cd31cfe1c346e4bce3 (patch)
treeb39773ccf545be51fcbb1bb40ae151e53d2d61fa /recipes/libtool/libtool_2.2.6a.bb
parent6eea2d81d154d7d1e12e89676e3246ac434360f1 (diff)
downloadopenembedded-2e0fa4918d643ce6ec0299cd31cfe1c346e4bce3.tar.gz
libtool: Fixed paths to grep and sed.
Diffstat (limited to 'recipes/libtool/libtool_2.2.6a.bb')
-rw-r--r--recipes/libtool/libtool_2.2.6a.bb12
1 files changed, 11 insertions, 1 deletions
diff --git a/recipes/libtool/libtool_2.2.6a.bb b/recipes/libtool/libtool_2.2.6a.bb
index 9ecd7a0f3b..6268576da6 100644
--- a/recipes/libtool/libtool_2.2.6a.bb
+++ b/recipes/libtool/libtool_2.2.6a.bb
@@ -1,5 +1,5 @@
require libtool.inc
-PR = "r0"
+PR = "r1"
SRC_URI = "${GNU_MIRROR}/libtool/libtool-${PV}.tar.gz"
S = "${WORKDIR}/${BPN}-2.2.6"
@@ -14,6 +14,16 @@ inherit autotools
EXTRA_AUTORECONF = "--exclude=libtoolize"
+do_configure_prepend () {
+ # Skip this for native build:
+ if test -n "$CONFIG_SITE" ; then
+ export ac_cv_path_SED=${ac_cv_path_GREP=/bin/sed}
+ export ac_cv_path_GREP=${ac_cv_path_GREP=/bin/grep}
+ export ac_cv_path_EGREP=${ac_cv_path_EGREP=/bin/grep -E}
+ export ac_cv_path_FGREP=${ac_cv_path_FGREP=/bin/grep -F}
+ fi
+}
+
do_stage () {
install -d ${STAGING_INCDIR}/libltdl
install -m 0644 libltdl/ltdl.h ${STAGING_INCDIR}/