aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libtool
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-05-24 13:01:00 -0700
committerChris Larson <chris_larson@mentor.com>2010-05-25 12:54:52 -0700
commit6fe7cef27069415f2eba36bc640cf59013d4979b (patch)
treeb0cb8845ddc6b8bcffc50e08a2eeae98e049be98 /recipes/libtool
parentbf7d0467a0788a7fcc1c96e0dc35a25ae09278a0 (diff)
downloadopenembedded-6fe7cef27069415f2eba36bc640cf59013d4979b.tar.gz
Make the do_patch apply=yes param implicit if extension is .diff/.patch
For .diff/.patch you need to apply manually, you can specify apply=no. Signed-off-by: Chris Larson <chris_larson@mentor.com> Acked-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/libtool')
-rw-r--r--recipes/libtool/libtool-cross_1.5.10.bb16
-rw-r--r--recipes/libtool/libtool-cross_1.5.22.bb12
-rw-r--r--recipes/libtool/libtool-cross_1.5.24.bb10
-rw-r--r--recipes/libtool/libtool-cross_2.2.4.bb8
-rw-r--r--recipes/libtool/libtool-cross_2.2.6a.bb8
-rw-r--r--recipes/libtool/libtool-cross_2.2.6b.bb8
-rw-r--r--recipes/libtool/libtool-native_1.5.10.bb12
-rw-r--r--recipes/libtool/libtool-native_1.5.22.bb10
-rw-r--r--recipes/libtool/libtool-native_1.5.24.bb10
-rw-r--r--recipes/libtool/libtool-native_2.2.4.bb4
-rw-r--r--recipes/libtool/libtool-native_2.2.6a.bb4
-rw-r--r--recipes/libtool/libtool-native_2.2.6b.bb4
-rw-r--r--recipes/libtool/libtool-sdk_1.5.10.bb16
-rw-r--r--recipes/libtool/libtool-sdk_2.2.4.bb2
-rw-r--r--recipes/libtool/libtool-sdk_2.2.6a.bb2
-rw-r--r--recipes/libtool/libtool-sdk_2.2.6b.bb2
-rw-r--r--recipes/libtool/libtool_1.5.10.bb6
-rw-r--r--recipes/libtool/libtool_1.5.22.bb6
-rw-r--r--recipes/libtool/libtool_1.5.24.bb6
-rw-r--r--recipes/libtool/libtool_1.5.6.bb2
20 files changed, 74 insertions, 74 deletions
diff --git a/recipes/libtool/libtool-cross_1.5.10.bb b/recipes/libtool/libtool-cross_1.5.10.bb
index b3c7ef9603..78ebc45c75 100644
--- a/recipes/libtool/libtool-cross_1.5.10.bb
+++ b/recipes/libtool/libtool-cross_1.5.10.bb
@@ -2,14 +2,14 @@ require libtool_${PV}.bb
PR = "${INC_PR}.0"
PACKAGES = ""
-SRC_URI_append = " file://rpath-control.patch;apply=yes \
- file://libdir-la.patch;apply=yes \
- file://libdir-la2.patch;apply=yes \
- file://prefix.patch;apply=yes \
- file://tag.patch;apply=yes \
- file://install-path-check.patch;apply=yes \
- file://nmedit_fix.patch;apply=yes \
- file://nousrlib.patch;apply=yes"
+SRC_URI_append = " file://rpath-control.patch \
+ file://libdir-la.patch \
+ file://libdir-la2.patch \
+ file://prefix.patch \
+ file://tag.patch \
+ file://install-path-check.patch \
+ file://nmedit_fix.patch \
+ file://nousrlib.patch"
S = "${WORKDIR}/libtool-${PV}"
diff --git a/recipes/libtool/libtool-cross_1.5.22.bb b/recipes/libtool/libtool-cross_1.5.22.bb
index b9cf5a51a8..03d664a088 100644
--- a/recipes/libtool/libtool-cross_1.5.22.bb
+++ b/recipes/libtool/libtool-cross_1.5.22.bb
@@ -4,12 +4,12 @@ require libtool_${PV}.bb
PR = "${INC_PR}.0"
PACKAGES = ""
-SRC_URI_append = " file://libdir-la.patch;apply=yes \
- file://prefix.patch;apply=yes \
- file://tag.patch;apply=yes \
- file://tag1.patch;apply=yes \
-# file://rpath.patch;apply=yes \
- file://install-path-check.patch;apply=yes"
+SRC_URI_append = " file://libdir-la.patch \
+ file://prefix.patch \
+ file://tag.patch \
+ file://tag1.patch \
+# file://rpath.patch \
+ file://install-path-check.patch"
S = "${WORKDIR}/libtool-${PV}"
prefix = "${STAGING_DIR_NATIVE}${prefix_native}"
diff --git a/recipes/libtool/libtool-cross_1.5.24.bb b/recipes/libtool/libtool-cross_1.5.24.bb
index 9d19f65444..c8f53ca282 100644
--- a/recipes/libtool/libtool-cross_1.5.24.bb
+++ b/recipes/libtool/libtool-cross_1.5.24.bb
@@ -2,11 +2,11 @@ require libtool_${PV}.bb
PR = "${INC_PR}.0"
PACKAGES = ""
-SRC_URI_append = " file://libdir-la.patch;apply=yes \
- file://prefix.patch;apply=yes \
- file://tag.patch;apply=yes \
- file://tag1.patch;apply=yes \
- file://install-path-check.patch;apply=yes"
+SRC_URI_append = " file://libdir-la.patch \
+ file://prefix.patch \
+ file://tag.patch \
+ file://tag1.patch \
+ file://install-path-check.patch"
S = "${WORKDIR}/libtool-${PV}"
prefix = "${STAGING_DIR_NATIVE}${prefix_native}"
diff --git a/recipes/libtool/libtool-cross_2.2.4.bb b/recipes/libtool/libtool-cross_2.2.4.bb
index b37bef1113..6e6caf958d 100644
--- a/recipes/libtool/libtool-cross_2.2.4.bb
+++ b/recipes/libtool/libtool-cross_2.2.4.bb
@@ -2,15 +2,15 @@ require libtool_${PV}.bb
PR = "${INC_PR}.0"
SRC_URI += "\
- file://cross_compile.patch;apply=yes \
- file://prefix.patch;apply=yes \
+ file://cross_compile.patch \
+ file://prefix.patch \
"
DEPENDS += "libtool-native"
DOLT_PATCH = ""
-DOLT_PATCH_arm = " file://add_dolt.patch;apply=yes"
-DOLT_PATCH_i586 = " file://add_dolt.patch;apply=yes"
+DOLT_PATCH_arm = " file://add_dolt.patch"
+DOLT_PATCH_i586 = " file://add_dolt.patch"
#SRC_URI_append_linux = "${DOLT_PATCH}"
#SRC_URI_append_linux-gnueabi = "${DOLT_PATCH}"
diff --git a/recipes/libtool/libtool-cross_2.2.6a.bb b/recipes/libtool/libtool-cross_2.2.6a.bb
index 44147c8c38..0303cbb349 100644
--- a/recipes/libtool/libtool-cross_2.2.6a.bb
+++ b/recipes/libtool/libtool-cross_2.2.6a.bb
@@ -2,15 +2,15 @@ require libtool_${PV}.bb
PR = "${INC_PR}.0"
SRC_URI += "\
- file://cross_compile.patch;apply=yes \
- file://prefix.patch;apply=yes \
+ file://cross_compile.patch \
+ file://prefix.patch \
"
DEPENDS += "libtool-native"
DOLT_PATCH = ""
-DOLT_PATCH_arm = " file://add_dolt.patch;apply=yes"
-DOLT_PATCH_i586 = " file://add_dolt.patch;apply=yes"
+DOLT_PATCH_arm = " file://add_dolt.patch"
+DOLT_PATCH_i586 = " file://add_dolt.patch"
#SRC_URI_append_linux = "${DOLT_PATCH}"
#SRC_URI_append_linux-gnueabi = "${DOLT_PATCH}"
diff --git a/recipes/libtool/libtool-cross_2.2.6b.bb b/recipes/libtool/libtool-cross_2.2.6b.bb
index 44147c8c38..0303cbb349 100644
--- a/recipes/libtool/libtool-cross_2.2.6b.bb
+++ b/recipes/libtool/libtool-cross_2.2.6b.bb
@@ -2,15 +2,15 @@ require libtool_${PV}.bb
PR = "${INC_PR}.0"
SRC_URI += "\
- file://cross_compile.patch;apply=yes \
- file://prefix.patch;apply=yes \
+ file://cross_compile.patch \
+ file://prefix.patch \
"
DEPENDS += "libtool-native"
DOLT_PATCH = ""
-DOLT_PATCH_arm = " file://add_dolt.patch;apply=yes"
-DOLT_PATCH_i586 = " file://add_dolt.patch;apply=yes"
+DOLT_PATCH_arm = " file://add_dolt.patch"
+DOLT_PATCH_i586 = " file://add_dolt.patch"
#SRC_URI_append_linux = "${DOLT_PATCH}"
#SRC_URI_append_linux-gnueabi = "${DOLT_PATCH}"
diff --git a/recipes/libtool/libtool-native_1.5.10.bb b/recipes/libtool/libtool-native_1.5.10.bb
index 28af0f4e2f..304189c3fc 100644
--- a/recipes/libtool/libtool-native_1.5.10.bb
+++ b/recipes/libtool/libtool-native_1.5.10.bb
@@ -1,12 +1,12 @@
require libtool_${PV}.bb
PR = "${INC_PR}.0"
-SRC_URI_append = " file://libdir-la.patch;apply=yes \
- file://libdir-la2.patch;apply=yes \
- file://prefix.patch;apply=yes \
- file://tag.patch;apply=yes \
- file://install-path-check.patch;apply=yes \
- file://nousrlib.patch;apply=yes"
+SRC_URI_append = " file://libdir-la.patch \
+ file://libdir-la2.patch \
+ file://prefix.patch \
+ file://tag.patch \
+ file://install-path-check.patch \
+ file://nousrlib.patch"
S = "${WORKDIR}/libtool-${PV}"
diff --git a/recipes/libtool/libtool-native_1.5.22.bb b/recipes/libtool/libtool-native_1.5.22.bb
index 028fabf466..dad2dc2a4d 100644
--- a/recipes/libtool/libtool-native_1.5.22.bb
+++ b/recipes/libtool/libtool-native_1.5.22.bb
@@ -3,11 +3,11 @@ DEFAULT_PREFERENCE = "-1"
require libtool_${PV}.bb
PR = "${INC_PR}.0"
-SRC_URI_append = " file://libdir-la.patch;apply=yes \
- file://prefix.patch;apply=yes \
- file://tag.patch;apply=yes \
- file://tag1.patch;apply=yes \
- file://install-path-check.patch;apply=yes"
+SRC_URI_append = " file://libdir-la.patch \
+ file://prefix.patch \
+ file://tag.patch \
+ file://tag1.patch \
+ file://install-path-check.patch"
S = "${WORKDIR}/libtool-${PV}"
inherit native
diff --git a/recipes/libtool/libtool-native_1.5.24.bb b/recipes/libtool/libtool-native_1.5.24.bb
index a0e17e3e5c..0e315e8b2b 100644
--- a/recipes/libtool/libtool-native_1.5.24.bb
+++ b/recipes/libtool/libtool-native_1.5.24.bb
@@ -3,11 +3,11 @@ SECTION = "devel"
require libtool_${PV}.bb
PR = "${INC_PR}.0"
-SRC_URI_append = " file://libdir-la.patch;apply=yes \
- file://prefix.patch;apply=yes \
- file://tag.patch;apply=yes \
- file://tag1.patch;apply=yes \
- file://install-path-check.patch;apply=yes"
+SRC_URI_append = " file://libdir-la.patch \
+ file://prefix.patch \
+ file://tag.patch \
+ file://tag1.patch \
+ file://install-path-check.patch"
S = "${WORKDIR}/libtool-${PV}"
inherit native
diff --git a/recipes/libtool/libtool-native_2.2.4.bb b/recipes/libtool/libtool-native_2.2.4.bb
index f2ca52d59b..b241d0c8f6 100644
--- a/recipes/libtool/libtool-native_2.2.4.bb
+++ b/recipes/libtool/libtool-native_2.2.4.bb
@@ -2,8 +2,8 @@ require libtool_${PV}.bb
PR = "${INC_PR}.0"
SRC_URI += "\
- file://cross_compile.patch;apply=yes \
- file://prefix.patch;apply=yes \
+ file://cross_compile.patch \
+ file://prefix.patch \
"
S = "${WORKDIR}/libtool-${PV}"
diff --git a/recipes/libtool/libtool-native_2.2.6a.bb b/recipes/libtool/libtool-native_2.2.6a.bb
index f27e62e827..fb83cf2258 100644
--- a/recipes/libtool/libtool-native_2.2.6a.bb
+++ b/recipes/libtool/libtool-native_2.2.6a.bb
@@ -2,8 +2,8 @@ require libtool_${PV}.bb
PR = "${INC_PR}.0"
SRC_URI += "\
- file://cross_compile.patch;apply=yes \
- file://prefix.patch;apply=yes \
+ file://cross_compile.patch \
+ file://prefix.patch \
"
inherit native
diff --git a/recipes/libtool/libtool-native_2.2.6b.bb b/recipes/libtool/libtool-native_2.2.6b.bb
index 992d0f56be..d5c7139d21 100644
--- a/recipes/libtool/libtool-native_2.2.6b.bb
+++ b/recipes/libtool/libtool-native_2.2.6b.bb
@@ -2,8 +2,8 @@ require libtool_${PV}.bb
PR = "${INC_PR}.1"
SRC_URI += "\
- file://cross_compile.patch;apply=yes \
- file://prefix.patch;apply=yes \
+ file://cross_compile.patch \
+ file://prefix.patch \
"
inherit native
diff --git a/recipes/libtool/libtool-sdk_1.5.10.bb b/recipes/libtool/libtool-sdk_1.5.10.bb
index f35b7223b6..10ed23dee6 100644
--- a/recipes/libtool/libtool-sdk_1.5.10.bb
+++ b/recipes/libtool/libtool-sdk_1.5.10.bb
@@ -1,14 +1,14 @@
require libtool_${PV}.bb
PR = "${INC_PR}.0"
-SRC_URI_append = " file://rpath-control.patch;apply=yes \
- file://libdir-la.patch;apply=yes \
- file://libdir-la2.patch;apply=yes \
- file://prefix.patch;apply=yes \
- file://tag.patch;apply=yes \
- file://install-path-check.patch;apply=yes \
- file://nousrlib.patch;apply=yes \
- file://add_sysroot_function.patch;apply=yes \
+SRC_URI_append = " file://rpath-control.patch \
+ file://libdir-la.patch \
+ file://libdir-la2.patch \
+ file://prefix.patch \
+ file://tag.patch \
+ file://install-path-check.patch \
+ file://nousrlib.patch \
+ file://add_sysroot_function.patch \
"
S = "${WORKDIR}/libtool-${PV}"
diff --git a/recipes/libtool/libtool-sdk_2.2.4.bb b/recipes/libtool/libtool-sdk_2.2.4.bb
index 88083b9797..5191ce3c31 100644
--- a/recipes/libtool/libtool-sdk_2.2.4.bb
+++ b/recipes/libtool/libtool-sdk_2.2.4.bb
@@ -2,7 +2,7 @@ require libtool_${PV}.bb
PR = "${INC_PR}.0"
-SRC_URI_append = " file://cross_compile.patch;apply=yes"
+SRC_URI_append = " file://cross_compile.patch"
S = "${WORKDIR}/libtool-${PV}"
diff --git a/recipes/libtool/libtool-sdk_2.2.6a.bb b/recipes/libtool/libtool-sdk_2.2.6a.bb
index f19d1b22dc..f7d6cb58a6 100644
--- a/recipes/libtool/libtool-sdk_2.2.6a.bb
+++ b/recipes/libtool/libtool-sdk_2.2.6a.bb
@@ -1,7 +1,7 @@
require libtool_${PV}.bb
PR = "${INC_PR}.0"
-SRC_URI_append = " file://cross_compile.patch;apply=yes"
+SRC_URI_append = " file://cross_compile.patch"
inherit sdk
diff --git a/recipes/libtool/libtool-sdk_2.2.6b.bb b/recipes/libtool/libtool-sdk_2.2.6b.bb
index f19d1b22dc..f7d6cb58a6 100644
--- a/recipes/libtool/libtool-sdk_2.2.6b.bb
+++ b/recipes/libtool/libtool-sdk_2.2.6b.bb
@@ -1,7 +1,7 @@
require libtool_${PV}.bb
PR = "${INC_PR}.0"
-SRC_URI_append = " file://cross_compile.patch;apply=yes"
+SRC_URI_append = " file://cross_compile.patch"
inherit sdk
diff --git a/recipes/libtool/libtool_1.5.10.bb b/recipes/libtool/libtool_1.5.10.bb
index b0d84803a1..56475aefaa 100644
--- a/recipes/libtool/libtool_1.5.10.bb
+++ b/recipes/libtool/libtool_1.5.10.bb
@@ -2,9 +2,9 @@ require libtool.inc
PR = "${INC_PR}.0"
SRC_URI = "${GNU_MIRROR}/libtool/libtool-${PV}.tar.gz \
- file://autotools.patch;apply=yes \
- file://uclibc.patch;apply=yes \
- file://3figures.patch;apply=yes"
+ file://autotools.patch \
+ file://uclibc.patch \
+ file://3figures.patch"
S = "${WORKDIR}/libtool-${PV}"
PACKAGES =+ "libltdl libltdl-dev libltdl-dbg"
diff --git a/recipes/libtool/libtool_1.5.22.bb b/recipes/libtool/libtool_1.5.22.bb
index 0335bf3453..2278cecdd5 100644
--- a/recipes/libtool/libtool_1.5.22.bb
+++ b/recipes/libtool/libtool_1.5.22.bb
@@ -4,9 +4,9 @@ require libtool.inc
PR = "${INC_PR}.0"
SRC_URI = "${GNU_MIRROR}/libtool/libtool-${PV}.tar.gz \
- file://autotools.patch;apply=yes \
- file://uclibc.patch;apply=yes"
-# file://3figures.patch;apply=yes"
+ file://autotools.patch \
+ file://uclibc.patch"
+# file://3figures.patch"
S = "${WORKDIR}/libtool-${PV}"
PACKAGES = "${PN}-dbg libltdl libltdl-dev ${PN}"
diff --git a/recipes/libtool/libtool_1.5.24.bb b/recipes/libtool/libtool_1.5.24.bb
index 15763949f9..6e3655a082 100644
--- a/recipes/libtool/libtool_1.5.24.bb
+++ b/recipes/libtool/libtool_1.5.24.bb
@@ -4,9 +4,9 @@ require libtool.inc
PR = "${INC_PR}.0"
SRC_URI = "${GNU_MIRROR}/libtool/libtool-${PV}.tar.gz \
- file://autotools.patch;apply=yes \
- file://uclibc.patch;apply=yes \
- file://never-ever-do-rpath.patch;apply=yes"
+ file://autotools.patch \
+ file://uclibc.patch \
+ file://never-ever-do-rpath.patch"
S = "${WORKDIR}/libtool-${PV}"
diff --git a/recipes/libtool/libtool_1.5.6.bb b/recipes/libtool/libtool_1.5.6.bb
index 303aa880fe..3a97d9e28b 100644
--- a/recipes/libtool/libtool_1.5.6.bb
+++ b/recipes/libtool/libtool_1.5.6.bb
@@ -6,7 +6,7 @@ PR = "${INC_PR}.0"
DEFAULT_PREFERENCE = "-1"
SRC_URI = "${GNU_MIRROR}/libtool/libtool-${PV}.tar.gz \
- file://autotools.patch;apply=yes"
+ file://autotools.patch"
S = "${WORKDIR}/libtool-${PV}"
PACKAGES = "libltdl libltdl-dbg libltdl-dev ${PN} ${PN}-doc"