aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libvalhalla
diff options
context:
space:
mode:
authorPaul Menzel <paulepanter@users.sourceforge.net>2010-03-19 05:27:05 +0000
committerKoen Kooi <koen@openembedded.org>2010-03-27 09:36:06 +0100
commite1d81df55535f8c2612ef8e46175e8bf5430006f (patch)
tree619c8c5b0b9fd7fcfc128158384d1e3322c99b61 /recipes/libvalhalla
parent3d746df179cf33ecc0e87318e242eb23f86a9e1a (diff)
downloadopenembedded-e1d81df55535f8c2612ef8e46175e8bf5430006f.tar.gz
libvalhalla: Add recipe for libvalhalla 1.0.1.
1. `--enable-pic` is needed for non-x86 architectures. 2. Put test programs in separate package `${PN}-bin`. Manual pages are in `${PN}-doc` though. 3. Build tested with GCC 4.4.3 and Binutils 2.20.1 for `MACHINE = "beagleboard"`. 4. Depend on `libnfo` since it is recommended on upstream’s Web site. `do_configure()` is based on the recipe of `ushare`. Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net> Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes/libvalhalla')
-rw-r--r--recipes/libvalhalla/libvalhalla.inc30
-rw-r--r--recipes/libvalhalla/libvalhalla_1.0.1.bb5
2 files changed, 35 insertions, 0 deletions
diff --git a/recipes/libvalhalla/libvalhalla.inc b/recipes/libvalhalla/libvalhalla.inc
new file mode 100644
index 0000000000..03b7cfd7aa
--- /dev/null
+++ b/recipes/libvalhalla/libvalhalla.inc
@@ -0,0 +1,30 @@
+DESCRIPTION = "libvalhalla is a library written in C. It is a media scanner, that stores various information in an SQLite database and relies on FFmpeg (libavformat and libavutil) and libcurl. It features many Internet grabbers that allows automatic download of covers, lyrics, informations on media files, tags retrival in video and music files and so on."
+HOMEPAGE = "http://libvalhalla.geexbox.org/"
+SECTION = "libs/multimedia"
+LICENSE = "LGPLv2.1"
+DEPENDS = "sqlite3 curl ffmpeg libnfo"
+
+INC_PR = "r0"
+
+SRC_URI = "http://libvalhalla.geexbox.org/releases/${P}.tar.bz2;name=${PN}"
+
+inherit autotools pkgconfig
+
+# the configure script is hand-crafted, it rejects some of the usual
+# configure arguments
+do_configure() {
+ ${S}/configure \
+ --prefix=${prefix} \
+ --disable-strip \
+ --with-lavf-inc=${STAGING_INCDIR} \
+ --with-lavf-lib=${STAGING_LIBDIR} \
+ --with-lavc-inc=${STAGING_INCDIR} \
+ --with-lavc-lib=${STAGING_LIBDIR} \
+ --cross-compile \
+ --enable-pic \
+ --enable-doc
+}
+
+PACKAGES =+ "${PN}-bin"
+
+FILES_${PN}-bin = "${bindir}/*"
diff --git a/recipes/libvalhalla/libvalhalla_1.0.1.bb b/recipes/libvalhalla/libvalhalla_1.0.1.bb
new file mode 100644
index 0000000000..9fe1f5e714
--- /dev/null
+++ b/recipes/libvalhalla/libvalhalla_1.0.1.bb
@@ -0,0 +1,5 @@
+require libvalhalla.inc
+PR = "${INC_PR}.0"
+
+SRC_URI[libvalhalla.md5sum] = "75d4a3383887c4c341eeba9ebe60d626"
+SRC_URI[libvalhalla.sha256sum] = "df78015e118c784e3ff3e8562bc96d287ac11997d3b9e45e2d8b67568b0600d3"