aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libvisual
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libvisual
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libvisual')
-rw-r--r--recipes/libvisual/libvisual-plugins_0.1.3.bb14
-rw-r--r--recipes/libvisual/libvisual_0.1.3.bb14
-rw-r--r--recipes/libvisual/libvisual_0.4.0.bb12
3 files changed, 40 insertions, 0 deletions
diff --git a/recipes/libvisual/libvisual-plugins_0.1.3.bb b/recipes/libvisual/libvisual-plugins_0.1.3.bb
new file mode 100644
index 0000000000..c76483b466
--- /dev/null
+++ b/recipes/libvisual/libvisual-plugins_0.1.3.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "A cross platform audio visualization library"
+HOMEPAGE = "http://libvisual.sf.net"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL"
+# FIXME: current depends dont support versioned deps well
+# DEPENDS = "libvisual (${PV})"
+DEPENDS = "libvisual"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/libvisual/libvisual-plugins-${PV}.tar.gz"
+
+inherit autotools
+
+FILES_${PN} += "${libdir}/libvisual/actor/*.so ${libdir}/libvisual/morph/*.so"
diff --git a/recipes/libvisual/libvisual_0.1.3.bb b/recipes/libvisual/libvisual_0.1.3.bb
new file mode 100644
index 0000000000..14f6a442ae
--- /dev/null
+++ b/recipes/libvisual/libvisual_0.1.3.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "A cross platform audio visualization library"
+HOMEPAGE = "http://libvisual.sf.net"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "LGPL GPL"
+SRC_URI = "${SOURCEFORGE_MIRROR}/libvisual/libvisual-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/libvisual/
+ install -m 0644 ${S}/libvisual/*.h ${STAGING_INCDIR}/libvisual/
+ oe_libinstall -so -C libvisual libvisual ${STAGING_LIBDIR}
+}
diff --git a/recipes/libvisual/libvisual_0.4.0.bb b/recipes/libvisual/libvisual_0.4.0.bb
new file mode 100644
index 0000000000..4c1eff1651
--- /dev/null
+++ b/recipes/libvisual/libvisual_0.4.0.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "A cross platform audio visualization library"
+HOMEPAGE = "http://libvisual.sf.net"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "LGPL GPL"
+SRC_URI = "${SOURCEFORGE_MIRROR}/libvisual/libvisual-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}