aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libxcomp/libxcomp_3.3.0-3.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libxcomp/libxcomp_3.3.0-3.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libxcomp/libxcomp_3.3.0-3.bb')
-rw-r--r--recipes/libxcomp/libxcomp_3.3.0-3.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/libxcomp/libxcomp_3.3.0-3.bb b/recipes/libxcomp/libxcomp_3.3.0-3.bb
new file mode 100644
index 0000000000..fc4352627f
--- /dev/null
+++ b/recipes/libxcomp/libxcomp_3.3.0-3.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Compression library for x-protocol from nomachine"
+HOMEPAGE = "http://www.nomachine.com/"
+SECTION = "libs"
+LICENSE = "GPL"
+PR = "r0"
+
+DEPENDS = "virtual/libx11 zlib jpeg libpng"
+
+SRC_URI = "http://64.34.161.181/download/3.3.0/sources/nxcomp-${PV}.tar.gz \
+ "
+
+
+inherit autotools
+
+S = "${WORKDIR}/nxcomp"
+
+do_install () {
+ oe_libinstall -a -so libXcomp ${D}${libdir}
+ install -d ${D}${includedir}/
+ install -m 0644 NX.h ${D}${includedir}/
+}
+
+
+do_stage () {
+ oe_libinstall -a -so libXcomp ${STAGING_LIBDIR}
+ install -m 0644 NX.h ${STAGING_INCDIR}/
+}