aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libxine/libxine_1.1.16.bb
diff options
context:
space:
mode:
authorwoglinde <heinold@inf.fu-berlin.de>2009-03-28 16:15:51 +0100
committerwoglinde <heinold@inf.fu-berlin.de>2009-04-01 23:00:01 +0200
commite59631d0854718461cf9c31fdf243a077ccac290 (patch)
tree16c4409e4d7f0b5128e136f0f6c0a68b5be8119e /recipes/libxine/libxine_1.1.16.bb
parent791a9bc3f0fbcd4f44bda9dc7cd6cfaa709aefa0 (diff)
downloadopenembedded-e59631d0854718461cf9c31fdf243a077ccac290.tar.gz
libxine: remove older verison and add the actual 1.1.16
* dont seperate x11 and fb anymore xine can handle it via plugins * therefore all recipes wich depends on libxine-fb or libxine-x11 have to changed to libxine
Diffstat (limited to 'recipes/libxine/libxine_1.1.16.bb')
-rw-r--r--recipes/libxine/libxine_1.1.16.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes/libxine/libxine_1.1.16.bb b/recipes/libxine/libxine_1.1.16.bb
new file mode 100644
index 0000000000..c46b39303c
--- /dev/null
+++ b/recipes/libxine/libxine_1.1.16.bb
@@ -0,0 +1,39 @@
+require libxine.inc
+
+PPDIR = "1.25"
+PR = "r0"
+
+
+SRC_URI += " \
+ file://libxine-arm-configure.patch;patch=1 \
+ file://iconv.patch;patch=1 \
+ file://libpostproc.patch;patch=1 \
+ file://libavcodec.patch;patch=1 \
+ "
+
+python populate_packages_prepend () {
+ bb.data.setVar('PKG_libxine', 'libxine', d)
+
+ plugindir = bb.data.expand('${libdir}/xine/plugins/${PPDIR}', d)
+ do_split_packages(d, plugindir, '^xineplug_(.*)\.so$', 'libxine-plugin-%s', 'Xine plugin for %s', extra_depends='' )
+
+ vidixdir = bb.data.expand('${libdir}/xine/plugins/${PPDIR}/vidix', d)
+ do_split_packages(d, vidixdir, '^(.*)\.so$', 'libxine-plugin-%s', 'Xine plugin for %s', extra_depends='' )
+
+ postdir = bb.data.expand('${libdir}/xine/plugins/${PPDIR}/post', d)
+ do_split_packages(d, postdir, '^xineplug_(.*)\.so$', 'libxine-plugin-%s', 'Xine plugin for %s', extra_depends='' )
+
+ fontdir = bb.data.expand('${datadir}/xine/libxine1/fonts', d)
+ do_split_packages(d, fontdir, '^(.*).xinefont.gz$', 'libxine-font-%s', 'Xine font %s', extra_depends='' )
+
+}
+
+FILES_${PN}-dbg =+ "${libdir}/xine/plugins/${PPDIR}/.debug \
+ ${libdir}/xine/plugins/${PPDIR}/post/.debug \
+ ${libdir}/xine/plugins/${PPDIR}/vidix/.debug \
+ "
+
+FILES_${PN}-dev =+ "${libdir}/xine/plugins/${PPDIR}/*.a \
+ ${libdir}/xine/plugins/${PPDIR}/post/*.a \
+ ${libdir}/xine/plugins/${PPDIR}/vidix/*.a \
+ "