aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libxml
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-02-26 12:32:53 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-03-03 14:25:19 +0100
commit3cd9ddbfa1dc88247390e02c2e5b2b950a56885f (patch)
tree57db5e972c3413125175a41a616d9aae8e7dbc91 /recipes/libxml
parent4f499f5ed9139cc9a0ef1a01bb988246cacc533c (diff)
downloadopenembedded-3cd9ddbfa1dc88247390e02c2e5b2b950a56885f.tar.gz
libxml2: migrate -native to BBCLASSEXTEND
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/libxml')
-rw-r--r--recipes/libxml/libxml2-native.inc27
-rw-r--r--recipes/libxml/libxml2-native_2.7.3.bb2
-rw-r--r--recipes/libxml/libxml2.inc23
-rw-r--r--recipes/libxml/libxml2_2.7.3.bb2
4 files changed, 20 insertions, 34 deletions
diff --git a/recipes/libxml/libxml2-native.inc b/recipes/libxml/libxml2-native.inc
deleted file mode 100644
index 82d36b9f48..0000000000
--- a/recipes/libxml/libxml2-native.inc
+++ /dev/null
@@ -1,27 +0,0 @@
-DESCRIPTION = "GNOME XML library"
-DEPENDS = "python-native"
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libxml2-${PV}"
-
-SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz"
-S = "${WORKDIR}/libxml2-${PV}"
-
-inherit autotools native pkgconfig distutils-native-base
-
-do_configure_prepend () {
- EXTRA_LIBXML2_OECONF="\
- --with-python=${PYTHON_DIR} \
- --without-debug \
- --without-legacy \
- --with-catalog \
- --without-docbook \
- --with-c14n \
- "
-}
-
-do_configure (){
- autotools_do_configure ${EXTRA_LIBXML2_OECONF}
-}
-
-do_install_append() {
- :
-}
diff --git a/recipes/libxml/libxml2-native_2.7.3.bb b/recipes/libxml/libxml2-native_2.7.3.bb
deleted file mode 100644
index bcbfb6637b..0000000000
--- a/recipes/libxml/libxml2-native_2.7.3.bb
+++ /dev/null
@@ -1,2 +0,0 @@
-require libxml2-native.inc
-PR = "r1"
diff --git a/recipes/libxml/libxml2.inc b/recipes/libxml/libxml2.inc
index b324228a2e..62c81bd2e0 100644
--- a/recipes/libxml/libxml2.inc
+++ b/recipes/libxml/libxml2.inc
@@ -2,14 +2,26 @@ DESCRIPTION = "GNOME XML Parser library"
SECTION = "libs"
PRIORITY = "optional"
LICENSE = "MIT"
+DEPENDS_virtclass-native = "python-native"
-SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz"
+SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz;name=archive"
+S = "${WORKDIR}/${BPN}-${PV}"
-INC_PR = "r3"
+INC_PR = "r4"
-inherit autotools pkgconfig binconfig
+BBCLASSEXTEND = "native"
-EXTRA_OECONF = "--without-python --without-debug --without-legacy --with-catalog --with-docbook --with-c14n"
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "\
+ --without-debug \
+ --without-legacy \
+ --with-catalog \
+ --with-docbook \
+ --with-c14n"
+
+EXTRA_OECONF_append = " --without-python"
+EXTRA_OECONF_append_virtclass-native = " --with-python=${PYTHON_DIR}"
export LDFLAGS += "-ldl"
@@ -18,6 +30,9 @@ do_install_append() {
#this is need it by php during its install
install -m 0755 xml2-config ${STAGING_BINDIR_CROSS}
}
+do_install_append_virtclass-native() {
+ :
+}
DEBIANNAME_${PN} = "libxml2"
diff --git a/recipes/libxml/libxml2_2.7.3.bb b/recipes/libxml/libxml2_2.7.3.bb
index 5c92770eab..636ee91cd1 100644
--- a/recipes/libxml/libxml2_2.7.3.bb
+++ b/recipes/libxml/libxml2_2.7.3.bb
@@ -1,4 +1,4 @@
require libxml2.inc
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.0"