summaryrefslogtreecommitdiffstats
path: root/recipes/libxml
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libxml
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libxml')
-rw-r--r--recipes/libxml/libxml2-native.inc22
-rw-r--r--recipes/libxml/libxml2-native_2.7.2.bb2
-rw-r--r--recipes/libxml/libxml2.inc29
-rw-r--r--recipes/libxml/libxml2_2.7.2.bb4
4 files changed, 57 insertions, 0 deletions
diff --git a/recipes/libxml/libxml2-native.inc b/recipes/libxml/libxml2-native.inc
new file mode 100644
index 0000000000..603f48d196
--- /dev/null
+++ b/recipes/libxml/libxml2-native.inc
@@ -0,0 +1,22 @@
+DESCRIPTION = "GNOME XML library"
+DEPENDS = "python-native"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libxml2-${PV}"
+PR = "r3"
+
+SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz"
+S = "${WORKDIR}/libxml2-${PV}"
+
+inherit distutils-base autotools native pkgconfig
+
+EXTRA_OECONF = "\
+ --with-python=${STAGING_INCDIR}/${PYTHON_MAJMIN} \
+ --without-debug \
+ --without-legacy \
+ --without-catalog \
+ --without-docbook \
+ --with-c14n \
+"
+
+do_stage () {
+ oe_runmake install
+}
diff --git a/recipes/libxml/libxml2-native_2.7.2.bb b/recipes/libxml/libxml2-native_2.7.2.bb
new file mode 100644
index 0000000000..48e35986f6
--- /dev/null
+++ b/recipes/libxml/libxml2-native_2.7.2.bb
@@ -0,0 +1,2 @@
+require libxml2-native.inc
+PR = "r0"
diff --git a/recipes/libxml/libxml2.inc b/recipes/libxml/libxml2.inc
new file mode 100644
index 0000000000..f7ecaff977
--- /dev/null
+++ b/recipes/libxml/libxml2.inc
@@ -0,0 +1,29 @@
+DESCRIPTION = "GNOME XML Parser library"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "MIT"
+
+SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz"
+
+inherit autotools pkgconfig binconfig
+
+EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-catalog --without-docbook --with-c14n"
+
+export LDFLAGS += "-ldl"
+
+do_stage() {
+ autotools_stage_all
+ install -d ${STAGING_DATADIR}/aclocal/
+ install -d ${STAGING_BINDIR_CROSS}
+
+ install -m 0644 libxml.m4 ${STAGING_DATADIR}/aclocal/
+ #this is need it by php during its install
+ install -m 0755 xml2-config ${STAGING_BINDIR_CROSS}
+}
+
+DEBIANNAME_${PN} = "libxml2"
+
+PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
+
+FILES_${PN}-dev += "${bindir}/*-config"
+FILES_${PN}-utils += "${bindir}/* ${libdir}/*.sh"
diff --git a/recipes/libxml/libxml2_2.7.2.bb b/recipes/libxml/libxml2_2.7.2.bb
new file mode 100644
index 0000000000..555a436a63
--- /dev/null
+++ b/recipes/libxml/libxml2_2.7.2.bb
@@ -0,0 +1,4 @@
+require libxml2.inc
+
+PR = "r0"
+