summaryrefslogtreecommitdiffstats
path: root/recipes/libxml
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-03-23 21:06:36 -0700
committerKhem Raj <raj.khem@gmail.com>2009-03-23 21:06:36 -0700
commitc20e6cd2364611ecda9fee490840b5301c1546ce (patch)
tree54e71179adf864397d52b54892e4e13abced66a8 /recipes/libxml
parent9bb0079fdb658519027cd4bfa419ddae8a39334a (diff)
downloadopenembedded-c20e6cd2364611ecda9fee490840b5301c1546ce.tar.gz
libxml2-native: Move EXTRA_OECONF to do_configure_prepend
* EXTRA_OECONF uses --with-python=${PYTHON_DIR} and PYTHON_DIR is a python evaluated. So unless we have python-native built and installed in staging we can not evaluate this variable. We move this evaluation inside do_configure so that it gets evluated after dependency is met. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/libxml')
-rw-r--r--recipes/libxml/libxml2-native.inc18
-rw-r--r--recipes/libxml/libxml2-native_2.7.2.bb2
2 files changed, 11 insertions, 9 deletions
diff --git a/recipes/libxml/libxml2-native.inc b/recipes/libxml/libxml2-native.inc
index b819f95fba..c8182de91a 100644
--- a/recipes/libxml/libxml2-native.inc
+++ b/recipes/libxml/libxml2-native.inc
@@ -7,14 +7,16 @@ S = "${WORKDIR}/libxml2-${PV}"
inherit distutils-base autotools native pkgconfig
-EXTRA_OECONF = "\
- --with-python=${PYTHON_DIR} \
- --without-debug \
- --without-legacy \
- --with-catalog \
- --without-docbook \
- --with-c14n \
-"
+do_configure_prepend () {
+ EXTRA_OECONF = "\
+ --with-python=${PYTHON_DIR} \
+ --without-debug \
+ --without-legacy \
+ --with-catalog \
+ --without-docbook \
+ --with-c14n \
+ "
+}
do_stage () {
oe_runmake install
diff --git a/recipes/libxml/libxml2-native_2.7.2.bb b/recipes/libxml/libxml2-native_2.7.2.bb
index bcbfb6637b..24261d66f2 100644
--- a/recipes/libxml/libxml2-native_2.7.2.bb
+++ b/recipes/libxml/libxml2-native_2.7.2.bb
@@ -1,2 +1,2 @@
require libxml2-native.inc
-PR = "r1"
+PR = "r2"