aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libxslt
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libxslt
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libxslt')
-rw-r--r--recipes/libxslt/files/destdir.patch10
-rw-r--r--recipes/libxslt/files/pkgconfig_fix.patch22
-rw-r--r--recipes/libxslt/libxslt-native_1.1.17.bb4
-rw-r--r--recipes/libxslt/libxslt-native_1.1.21.bb4
-rw-r--r--recipes/libxslt/libxslt_1.1.17.bb46
-rw-r--r--recipes/libxslt/libxslt_1.1.21.bb22
-rw-r--r--recipes/libxslt/libxslt_1.1.22.bb23
7 files changed, 131 insertions, 0 deletions
diff --git a/recipes/libxslt/files/destdir.patch b/recipes/libxslt/files/destdir.patch
new file mode 100644
index 0000000000..8df1b206bc
--- /dev/null
+++ b/recipes/libxslt/files/destdir.patch
@@ -0,0 +1,10 @@
+Index: libxslt-1.1.17/libxslt/Makefile.am
+===================================================================
+--- libxslt-1.1.17.orig/libxslt/Makefile.am 2005-10-02 11:25:21.000000000 +0200
++++ libxslt-1.1.17/libxslt/Makefile.am 2006-09-29 23:13:35.000000000 +0200
+@@ -61,4 +61,4 @@
+ @(cd ../xsltproc ; $(MAKE))
+
+ install-exec-hook:
+- $(mkinstalldirs) "$(libdir)/libxslt-plugins"
++ $(mkinstalldirs) "$(DESTDIR)$(libdir)/libxslt-plugins"
diff --git a/recipes/libxslt/files/pkgconfig_fix.patch b/recipes/libxslt/files/pkgconfig_fix.patch
new file mode 100644
index 0000000000..5e4a38f0b2
--- /dev/null
+++ b/recipes/libxslt/files/pkgconfig_fix.patch
@@ -0,0 +1,22 @@
+Index: libxslt-1.1.22/libexslt.pc.in
+===================================================================
+--- libxslt-1.1.22.orig/libexslt.pc.in 2008-03-19 16:52:20.000000000 +0000
++++ libxslt-1.1.22/libexslt.pc.in 2008-03-19 16:55:49.000000000 +0000
+@@ -8,5 +8,5 @@
+ Version: @LIBEXSLT_VERSION@
+ Description: EXSLT Extension library
+ Requires: libxml-2.0
+-Libs: @EXSLT_LIBDIR@ @EXSLT_LIBS@
++Libs: -lxslt @EXSLT_LIBDIR@ @M_LIBS@
+ Cflags: @EXSLT_INCLUDEDIR@
+Index: libxslt-1.1.22/libxslt.pc.in
+===================================================================
+--- libxslt-1.1.22.orig/libxslt.pc.in 2008-03-19 16:52:20.000000000 +0000
++++ libxslt-1.1.22/libxslt.pc.in 2008-03-19 16:55:38.000000000 +0000
+@@ -8,5 +8,5 @@
+ Version: @VERSION@
+ Description: XSLT library version 2.
+ Requires: libxml-2.0
+-Libs: @XSLT_LIBDIR@ @XSLT_LIBS@
++Libs: -lxslt @XSLT_LIBDIR@ @M_LIBS@
+ Cflags: @XSLT_INCLUDEDIR@
diff --git a/recipes/libxslt/libxslt-native_1.1.17.bb b/recipes/libxslt/libxslt-native_1.1.17.bb
new file mode 100644
index 0000000000..6134b2bf57
--- /dev/null
+++ b/recipes/libxslt/libxslt-native_1.1.17.bb
@@ -0,0 +1,4 @@
+require libxslt_${PV}.bb
+inherit native
+
+DEPENDS = "libxml2-native (>=2.6.25)"
diff --git a/recipes/libxslt/libxslt-native_1.1.21.bb b/recipes/libxslt/libxslt-native_1.1.21.bb
new file mode 100644
index 0000000000..5157aaacbf
--- /dev/null
+++ b/recipes/libxslt/libxslt-native_1.1.21.bb
@@ -0,0 +1,4 @@
+require libxslt_${PV}.bb
+inherit native
+
+DEPENDS = "libxml2-native (>=2.6.27)"
diff --git a/recipes/libxslt/libxslt_1.1.17.bb b/recipes/libxslt/libxslt_1.1.17.bb
new file mode 100644
index 0000000000..d4fadc401b
--- /dev/null
+++ b/recipes/libxslt/libxslt_1.1.17.bb
@@ -0,0 +1,46 @@
+DESCRIPTION = "GNOME XSLT library"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "libxml2"
+LICENSE = "MIT"
+PR = "r3"
+
+SRC_URI = "ftp://xmlsoft.org/libxml2/libxslt-${PV}.tar.gz \
+ file://destdir.patch;patch=1"
+S = "${WORKDIR}/libxslt-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--without-python --without-plugins --without-debug --without-mem-debug --without-crypto"
+
+xsltheaders = "attributes.h documents.h extensions.h extra.h functions.h imports.h \
+ keys.h namespaces.h numbersInternals.h pattern.h preproc.h security.h \
+ templates.h transform.h variables.h xslt.h xsltInternals.h xsltconfig.h \
+ xsltexports.h xsltutils.h"
+exsltheaders = "exslt.h exsltconfig.h exsltexports.h"
+
+do_stage () {
+ oe_libinstall -C libxslt -so -a libxslt ${STAGING_LIBDIR}
+ oe_libinstall -C libexslt -so -a libexslt ${STAGING_LIBDIR}
+
+ mkdir -p ${STAGING_INCDIR}/libxslt
+ for i in ${xsltheaders}; do
+ install -m 0644 ${S}/libxslt/$i ${STAGING_INCDIR}/libxslt/$i
+ done
+ mkdir -p ${STAGING_INCDIR}/libexslt
+ for i in ${exsltheaders}; do
+ install -m 0644 ${S}/libexslt/$i ${STAGING_INCDIR}/libexslt/$i
+ done
+
+ cat xslt-config | sed -e "s,^prefix=.*,prefix=${STAGING_DIR_HOST}${layout_prefix}," \
+ -e "s,^exec_prefix=.*,exec_prefix=${STAGING_DIR_HOST}${layout_exec_prefix}," \
+ -e "s,^includedir=.*,includedir=${STAGING_INCDIR}," \
+ -e "s,^libdir=.*,libdir=${STAGING_LIBDIR}," > ${STAGING_BINDIR_CROSS}/xslt-config
+ chmod a+rx ${STAGING_BINDIR_CROSS}/xslt-config
+ install -m 0644 libxslt.m4 ${STAGING_DATADIR}/aclocal/
+}
+
+PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
+
+FILES_${PN}-dev += "${bindir}/xslt-config"
+FILES_${PN}-utils += "${bindir}"
diff --git a/recipes/libxslt/libxslt_1.1.21.bb b/recipes/libxslt/libxslt_1.1.21.bb
new file mode 100644
index 0000000000..282918e83e
--- /dev/null
+++ b/recipes/libxslt/libxslt_1.1.21.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "GNOME XSLT library"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "libxml2 (>=2.6.27)"
+LICENSE = "MIT"
+PR = "r2"
+
+SRC_URI = "ftp://xmlsoft.org/libxml2/libxslt-${PV}.tar.gz"
+S = "${WORKDIR}/libxslt-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
+
+do_stage () {
+ autotools_stage_all
+}
+
+PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
+
+FILES_${PN}-dev += "${bindir}/xslt-config"
+FILES_${PN}-utils += "${bindir}"
diff --git a/recipes/libxslt/libxslt_1.1.22.bb b/recipes/libxslt/libxslt_1.1.22.bb
new file mode 100644
index 0000000000..86fe70dff2
--- /dev/null
+++ b/recipes/libxslt/libxslt_1.1.22.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "GNOME XSLT library"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "libxml2 (>=2.6.27)"
+LICENSE = "MIT"
+PR = "r1"
+
+SRC_URI = "ftp://xmlsoft.org/libxml2/libxslt-${PV}.tar.gz \
+ file://pkgconfig_fix.patch;patch=1"
+S = "${WORKDIR}/libxslt-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
+
+do_stage () {
+ autotools_stage_all
+}
+
+PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
+
+FILES_${PN}-dev += "${bindir}/xslt-config"
+FILES_${PN}-utils += "${bindir}"