aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libxslt
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-03-26 08:28:58 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-03-26 08:37:33 +0100
commit72d20d2be3dacb05059ddccdcedda86697786752 (patch)
treed2ebb27130b122b92867301c64d8a09adc2bc846 /recipes/libxslt
parent2493fb3e3287c35d3fda037c1dbf2cfd0894ab37 (diff)
downloadopenembedded-72d20d2be3dacb05059ddccdcedda86697786752.tar.gz
libxslt: introduce libxslt.inc, move checksums to recipe, add 1.1.26
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/libxslt')
-rw-r--r--recipes/libxslt/libxslt.inc21
-rw-r--r--recipes/libxslt/libxslt_1.1.17.bb21
-rw-r--r--recipes/libxslt/libxslt_1.1.21.bb21
-rw-r--r--recipes/libxslt/libxslt_1.1.22.bb26
-rw-r--r--recipes/libxslt/libxslt_1.1.26.bb4
5 files changed, 40 insertions, 53 deletions
diff --git a/recipes/libxslt/libxslt.inc b/recipes/libxslt/libxslt.inc
new file mode 100644
index 0000000000..d2a4400700
--- /dev/null
+++ b/recipes/libxslt/libxslt.inc
@@ -0,0 +1,21 @@
+DESCRIPTION = "GNOME XSLT library"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "libxml2 (>=2.6.27)"
+LICENSE = "MIT"
+INC_PR = "r4"
+
+SRC_URI = "ftp://xmlsoft.org/libxml2/${BPN}-${PV}.tar.gz;name=archive"
+S = "${WORKDIR}/${BPN}-${PV}"
+
+inherit autotools pkgconfig
+
+NATIVE_INSTALL_WORKS = "1"
+BBCLASSEXTEND = "native"
+
+EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
+
+PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
+
+FILES_${PN}-dev += "${bindir}/xslt-config"
+FILES_${PN}-utils += "${bindir}"
diff --git a/recipes/libxslt/libxslt_1.1.17.bb b/recipes/libxslt/libxslt_1.1.17.bb
index d4fadc401b..d52791fa30 100644
--- a/recipes/libxslt/libxslt_1.1.17.bb
+++ b/recipes/libxslt/libxslt_1.1.17.bb
@@ -1,17 +1,10 @@
-DESCRIPTION = "GNOME XSLT library"
-SECTION = "libs"
-PRIORITY = "optional"
+require libxslt.inc
DEPENDS = "libxml2"
-LICENSE = "MIT"
-PR = "r3"
+PR = "${INC_PR}.0"
-SRC_URI = "ftp://xmlsoft.org/libxml2/libxslt-${PV}.tar.gz \
- file://destdir.patch;patch=1"
-S = "${WORKDIR}/libxslt-${PV}"
+SRC_URI += " file://destdir.patch;patch=1"
-inherit autotools pkgconfig
-
-EXTRA_OECONF = "--without-python --without-plugins --without-debug --without-mem-debug --without-crypto"
+EXTRA_OECONF += " --without-plugins"
xsltheaders = "attributes.h documents.h extensions.h extra.h functions.h imports.h \
keys.h namespaces.h numbersInternals.h pattern.h preproc.h security.h \
@@ -40,7 +33,5 @@ do_stage () {
install -m 0644 libxslt.m4 ${STAGING_DATADIR}/aclocal/
}
-PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
-
-FILES_${PN}-dev += "${bindir}/xslt-config"
-FILES_${PN}-utils += "${bindir}"
+SRC_URI[archive.md5sum] = "fde6a7a93c0eb14cba628692fa3a1000"
+SRC_URI[archive.sha256sum] = "d337faebd64ddb8c52cde23df8469e1b3c65545af5f939e9bb4be9eeb9658c8a"
diff --git a/recipes/libxslt/libxslt_1.1.21.bb b/recipes/libxslt/libxslt_1.1.21.bb
index 282918e83e..34b5860357 100644
--- a/recipes/libxslt/libxslt_1.1.21.bb
+++ b/recipes/libxslt/libxslt_1.1.21.bb
@@ -1,22 +1,9 @@
-DESCRIPTION = "GNOME XSLT library"
-SECTION = "libs"
-PRIORITY = "optional"
-DEPENDS = "libxml2 (>=2.6.27)"
-LICENSE = "MIT"
-PR = "r2"
-
-SRC_URI = "ftp://xmlsoft.org/libxml2/libxslt-${PV}.tar.gz"
-S = "${WORKDIR}/libxslt-${PV}"
-
-inherit autotools pkgconfig
-
-EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
+require libxslt.inc
+PR = "${INC_PR}.0"
do_stage () {
autotools_stage_all
}
-PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
-
-FILES_${PN}-dev += "${bindir}/xslt-config"
-FILES_${PN}-utils += "${bindir}"
+SRC_URI[archive.md5sum] = "59fe34e85692f71df2a38c2ee291b3ca"
+SRC_URI[archive.sha256sum] = "ccefd4ceb29bb729dcaa9a9d4a86654a9134adfd29bdd72be1a9d3726efb54e0"
diff --git a/recipes/libxslt/libxslt_1.1.22.bb b/recipes/libxslt/libxslt_1.1.22.bb
index 068ff874cd..a93da16fc0 100644
--- a/recipes/libxslt/libxslt_1.1.22.bb
+++ b/recipes/libxslt/libxslt_1.1.22.bb
@@ -1,22 +1,6 @@
-DESCRIPTION = "GNOME XSLT library"
-SECTION = "libs"
-PRIORITY = "optional"
-DEPENDS = "libxml2 (>=2.6.27)"
-LICENSE = "MIT"
-PR = "r2"
+require libxslt.inc
+PR = "${INC_PR}.0"
-SRC_URI = "ftp://xmlsoft.org/libxml2/libxslt-${PV}.tar.gz \
- file://pkgconfig_fix.patch;patch=1"
-S = "${WORKDIR}/libxslt-${PV}"
-
-inherit autotools pkgconfig
-
-NATIVE_INSTALL_WORKS = "1"
-BBCLASSEXTEND = "native"
-
-EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
-
-PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
-
-FILES_${PN}-dev += "${bindir}/xslt-config"
-FILES_${PN}-utils += "${bindir}"
+SRC_URI += " file://pkgconfig_fix.patch;patch=1"
+SRC_URI[archive.md5sum] = "d6a9a020a76a3db17848d769d6c9c8a9"
+SRC_URI[archive.sha256sum] = "4e1f39ee16596fd2a83d28d6c3b065f742254f3336f93ce8ed1cae48ecbe49da"
diff --git a/recipes/libxslt/libxslt_1.1.26.bb b/recipes/libxslt/libxslt_1.1.26.bb
new file mode 100644
index 0000000000..8dfb33e1b6
--- /dev/null
+++ b/recipes/libxslt/libxslt_1.1.26.bb
@@ -0,0 +1,4 @@
+require libxslt.inc
+PR = "${INC_PR}.0"
+SRC_URI[archive.md5sum] = "e61d0364a30146aaa3001296f853b2b9"
+SRC_URI[archive.sha256sum] = "55dd52b42861f8a02989d701ef716d6280bfa02971e967c285016f99c66e3db1"