aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linphone/linphone-hh_0.12.2.hh1.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linphone/linphone-hh_0.12.2.hh1.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linphone/linphone-hh_0.12.2.hh1.bb')
-rw-r--r--recipes/linphone/linphone-hh_0.12.2.hh1.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes/linphone/linphone-hh_0.12.2.hh1.bb b/recipes/linphone/linphone-hh_0.12.2.hh1.bb
new file mode 100644
index 0000000000..54a79390a7
--- /dev/null
+++ b/recipes/linphone/linphone-hh_0.12.2.hh1.bb
@@ -0,0 +1,36 @@
+LICENSE = "GPL"
+SECTION = "x11/utils"
+PR = "r4"
+
+DESCRIPTION = "SIP-based IP phone (GPE edition)"
+DEPENDS = "libosip gtk+ libogg alsa-lib"
+SRC_URI = "http://handhelds.org/packages/linphone/linphone-${PV}.tar.gz \
+ file://osipua-ipv6-lossage.patch;patch=1 \
+ file://gpe-cross-lossage.patch;patch=1 \
+ file://disable-gtk-doc.patch;patch=1 \
+ file://dotdesktop.patch;patch=1 \
+ file://segfault.patch;patch=1"
+
+S = "${WORKDIR}/linphone-${PV}"
+
+FILES_${PN} += "${datadir}/linphonec"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-gnome_ui --disable-gtk-doc"
+
+do_configure() {
+ # ffmpeg is in AC_SUBDIRS, but doesn't actually use autoconf.
+ # Autoreconf will try to recurse into there and blow up.
+ for dir in . speex oRTP osipua; do
+ ( cd $dir; libtoolize --force; aclocal; automake; autoconf )
+ done
+
+ oe_runconf
+}
+
+do_install_append() {
+ mv ${D}${datadir}/gnome/apps/Internet ${D}${datadir}/applications
+ rm -f ${D}${datadir}/sounds/linphone/hello*.wav
+ rm -f ${D}${datadir}/sounds/linphone/rings/oldphone.wav
+}