summaryrefslogtreecommitdiffstats
path: root/recipes/linphone/linphone_1.3.99.8.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linphone/linphone_1.3.99.8.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linphone/linphone_1.3.99.8.bb')
-rw-r--r--recipes/linphone/linphone_1.3.99.8.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/linphone/linphone_1.3.99.8.bb b/recipes/linphone/linphone_1.3.99.8.bb
new file mode 100644
index 0000000000..f96bd66b82
--- /dev/null
+++ b/recipes/linphone/linphone_1.3.99.8.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "SIP-based IP phone (Console edition)"
+HOMEPAGE = "http://www.linphone.org/?lang=us"
+LICENSE = "GPL-2"
+DEPENDS = "libosip2 speex libogg alsa-lib readline"
+PR = "r0"
+
+SRC_URI = "http://download.savannah.nongnu.org/releases/linphone/unstable/source/linphone-${PV}.tar.gz \
+ file://conf.patch;patch=1"
+
+S = "${WORKDIR}/linphone-${PV}"
+
+FILES_${PN} += "${datadir}/linphonec"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-gnome_ui --disable-gtk-doc --without-ffmpeg \
+ --without-sdl --disable-video --enable-alsa \
+ --with-osip=${STAGING_DIR_HOST}${layout_exec_prefix} \
+ --with-readline=${STAGING_DIR_HOST}${layout_exec_prefix} \
+ --with-speex=${STAGING_DIR_HOST}${layout_exec_prefix} \
+ --disable-truespeech --disable-manual \
+ --disable-glibtest --disable-glib"
+
+do_install_append() {
+ rm -f ${D}${datadir}/sounds/linphone/hello*.wav
+ rm -f ${D}${datadir}/sounds/linphone/rings/oldphone.wav
+}