summaryrefslogtreecommitdiffstats
path: root/recipes/linux-hotplug/linux-hotplug-20040920
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux-hotplug/linux-hotplug-20040920
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux-hotplug/linux-hotplug-20040920')
-rw-r--r--recipes/linux-hotplug/linux-hotplug-20040920/dash.patch17
-rw-r--r--recipes/linux-hotplug/linux-hotplug-20040920/fix-net.agent29
-rw-r--r--recipes/linux-hotplug/linux-hotplug-20040920/hotplug-net-agent-usb.patch43
-rw-r--r--recipes/linux-hotplug/linux-hotplug-20040920/isapnp-exit.diff11
-rw-r--r--recipes/linux-hotplug/linux-hotplug-20040920/logcheck-ignore1
-rw-r--r--recipes/linux-hotplug/linux-hotplug-20040920/quiet-pci.patch11
-rwxr-xr-xrecipes/linux-hotplug/linux-hotplug-20040920/update-usb.usermap37
-rw-r--r--recipes/linux-hotplug/linux-hotplug-20040920/usb-storage2
-rw-r--r--recipes/linux-hotplug/linux-hotplug-20040920/usbrc-busybox.patch13
-rw-r--r--recipes/linux-hotplug/linux-hotplug-20040920/userspecified_hcd.patch55
10 files changed, 219 insertions, 0 deletions
diff --git a/recipes/linux-hotplug/linux-hotplug-20040920/dash.patch b/recipes/linux-hotplug/linux-hotplug-20040920/dash.patch
new file mode 100644
index 0000000000..161671f2e2
--- /dev/null
+++ b/recipes/linux-hotplug/linux-hotplug-20040920/dash.patch
@@ -0,0 +1,17 @@
+Index: hotplug-2004_09_20/Makefile
+===================================================================
+--- hotplug-2004_09_20.orig/Makefile 2006-11-29 17:01:16.000000000 +0100
++++ hotplug-2004_09_20/Makefile 2006-11-29 17:04:39.000000000 +0100
+@@ -86,10 +86,10 @@
+ ${INSTALL_SCRIPT} -D sbin/hotplug $(sbindir)/hotplug
+ $(INSTALL) -d $(etcdir)/hotplug/{usb,pci}
+ $(INSTALL) -D etc/hotplug.d/default/default.hotplug $(etcdir)/hotplug.d/default/default.hotplug
+- for F in etc/hotplug/{*.{agent,rc},hotplug.functions} ; do \
++ for F in etc/hotplug/*.agent etc/hotplug/*.rc etc/hotplug/hotplug.functions ; do \
+ ${INSTALL_SCRIPT} $$F $(etcdir)/hotplug ; \
+ done
+- for F in etc/hotplug/{blacklist,usb.{user,hand,dist}map} ; do \
++ for F in etc/hotplug/blacklist etc/hotplug/usb.*map ; do \
+ ${INSTALL_DATA} $$F $(etcdir)/hotplug ; \
+ done
+ ${INSTALL_SCRIPT} -D etc/rc.d/init.d/hotplug $(etcdir)/init.d/hotplug
diff --git a/recipes/linux-hotplug/linux-hotplug-20040920/fix-net.agent b/recipes/linux-hotplug/linux-hotplug-20040920/fix-net.agent
new file mode 100644
index 0000000000..3bc0935018
--- /dev/null
+++ b/recipes/linux-hotplug/linux-hotplug-20040920/fix-net.agent
@@ -0,0 +1,29 @@
+#!/bin/sh -e
+#
+# Since ifupdown of Debian is different than one of RedHat.
+# So we need to fix it
+
+topdir=$1
+dir=$topdir/etc/hotplug
+test -f $dir/net.agent || exit 1
+mv $dir/net.agent $dir/net.agent.orig
+
+sed -e '/^\*)/i\
+unregister)\
+ # Assume that we want to run ifdown no matter what, \
+ # because it is not going to remove the data from the \
+ # ifstate database otherwise.\
+ if [ -x /sbin/ifdown ]; then\
+ debug_mesg invoke ifdown $INTERFACE\
+ exec /sbin/ifdown $INTERFACE\
+ else\
+ # mesg "how do I bring interfaces up on this distro?"\
+ mesg "E: /sbin/ifdown not found. You need to install ifupdown package"\
+ fi\
+ mesg $1 $ACTION event not handled\
+ ;;\
+' $dir/net.agent.orig > $dir/net.agent
+rm -f $dir/net.agent.orig
+chmod 755 $dir/net.agent
+exit 0
+
diff --git a/recipes/linux-hotplug/linux-hotplug-20040920/hotplug-net-agent-usb.patch b/recipes/linux-hotplug/linux-hotplug-20040920/hotplug-net-agent-usb.patch
new file mode 100644
index 0000000000..a64fc50d2b
--- /dev/null
+++ b/recipes/linux-hotplug/linux-hotplug-20040920/hotplug-net-agent-usb.patch
@@ -0,0 +1,43 @@
+--- hotplug/etc/hotplug/net.agent 2005-01-13 21:12:47.143597392 +1300
++++ hotplug/etc/hotplug/net.agent 2005-01-13 21:17:57.095477544 +1300
+@@ -41,6 +41,9 @@
+ debug_mesg assuming $INTERFACE is already up
+ exit 0
+ ;;
++ # interfaces that don't go up until attached
++ usbf)
++ ;;
+ # interfaces that are registered then brought up
+ *)
+ # NOTE: network configuration relies on administered state,
+@@ -83,6 +86,13 @@
+ mesg $1 $ACTION event not handled
+ ;;
+
++attach)
++ # ifupdown is dumb and won't bring up an interface that it thinks
++ # might already be configured.
++ /sbin/ifdown $INTERFACE
++ exec /sbin/ifup $INTERFACE
++ ;;
++
+ remove|unregister)
+ case $INTERFACE in
+ # interfaces that are unregistered after being "down" (?)
+@@ -105,6 +115,16 @@
+ mesg $1 $ACTION event not handled
+ ;;
+
++detach)
++ if [ -x /sbin/ifdown ]; then
++ debug_mesg invoke ifdown $INTERFACE
++ exec /sbin/ifdown $INTERFACE
++ else
++ mesg "E: /sbin/ifdown not found. You need to install ifupdown package"
++ fi
++ mesg $1 $ACTION event not handled
++ ;;
++
+ *)
+ debug_mesg NET $ACTION event for $INTERFACE not supported
+ exit 1 ;;
diff --git a/recipes/linux-hotplug/linux-hotplug-20040920/isapnp-exit.diff b/recipes/linux-hotplug/linux-hotplug-20040920/isapnp-exit.diff
new file mode 100644
index 0000000000..e5a9ab10af
--- /dev/null
+++ b/recipes/linux-hotplug/linux-hotplug-20040920/isapnp-exit.diff
@@ -0,0 +1,11 @@
+--- hotplug-2004_09_20/etc/hotplug/isapnp.rc.orig 2004-12-20 15:01:21.541446000 +0100
++++ hotplug-2004_09_20/etc/hotplug/isapnp.rc 2004-12-20 15:01:32.625760928 +0100
+@@ -13,7 +13,7 @@
+ #
+
+ # only 2.6 kernels are supported
+-[ -d /sys/bus/pnp/devices/ ] || return 0
++[ -d /sys/bus/pnp/devices/ ] || exit 0
+
+ cd /etc/hotplug
+ . ./hotplug.functions
diff --git a/recipes/linux-hotplug/linux-hotplug-20040920/logcheck-ignore b/recipes/linux-hotplug/linux-hotplug-20040920/logcheck-ignore
new file mode 100644
index 0000000000..b941353041
--- /dev/null
+++ b/recipes/linux-hotplug/linux-hotplug-20040920/logcheck-ignore
@@ -0,0 +1 @@
+net.agent: invoke if(up|down)
diff --git a/recipes/linux-hotplug/linux-hotplug-20040920/quiet-pci.patch b/recipes/linux-hotplug/linux-hotplug-20040920/quiet-pci.patch
new file mode 100644
index 0000000000..5b4d169a2a
--- /dev/null
+++ b/recipes/linux-hotplug/linux-hotplug-20040920/quiet-pci.patch
@@ -0,0 +1,11 @@
+--- hotplug-2004_09_20/etc/hotplug/pci.rc.orig 2006-01-14 16:15:34.000000000 +0100
++++ hotplug-2004_09_20/etc/hotplug/pci.rc 2006-01-14 16:16:19.000000000 +0100
+@@ -45,7 +45,7 @@
+ # 2.4 kernels
+ LISTER=`which pcimodules`
+ if [ "$LISTER" = "" ] || [ ! -f /proc/bus/pci/devices ] || [ ! -x pci.agent ]; then
+- echo $"** can't synthesize pci hotplug events"
++ # echo $"** can't synthesize pci hotplug events"
+ return 1
+ fi
+
diff --git a/recipes/linux-hotplug/linux-hotplug-20040920/update-usb.usermap b/recipes/linux-hotplug/linux-hotplug-20040920/update-usb.usermap
new file mode 100755
index 0000000000..d09e1176ec
--- /dev/null
+++ b/recipes/linux-hotplug/linux-hotplug-20040920/update-usb.usermap
@@ -0,0 +1,37 @@
+#!/bin/sh -e
+# update-usb.usermap
+# Copyright (c) 2001 Fumitoshi UKAI <ukai@debian.or.jp>
+# GPL
+
+LIBDIR=/usr/lib/hotplug
+USERMAP=/etc/hotplug/usb.usermap
+LOCALMAP=/etc/hotplug/usb.usermap.local
+
+test -d $LIBDIR || exit 0
+
+echo -n "Updating $USERMAP ..."
+
+echo "# usb.usermap file" > $USERMAP
+echo "# This is autogenerated by update-usb.usermap program" >> $USERMAP
+echo "# usb module match_flags idVendor idProduct bcdDevice_lo bcdDevice_hi bDeviceClass bDeviceSubClass bDeviceProtocol bInterfaceClass bInterfaceSubClass bInterfaceProtocol driver_info" >> $USERMAP
+
+if [ -f $LOCALMAP ]; then
+ echo "# usb.usermap.local" >> $USERMAP
+ cat $LOCALMAP >> $USERMAP
+fi
+
+cd $LIBDIR
+for package in *
+do
+ if [ -d "$package" ]; then
+ map=$package/usb.usermap
+ echo "# $package" >> $USERMAP
+ if [ -x "$map" ]; then
+ ./$map >> $USERMAP
+ elif [ -f "$map" ]; then
+ cat $map >> $USERMAP
+ fi
+ fi
+done
+
+echo done.
diff --git a/recipes/linux-hotplug/linux-hotplug-20040920/usb-storage b/recipes/linux-hotplug/linux-hotplug-20040920/usb-storage
new file mode 100644
index 0000000000..138790a367
--- /dev/null
+++ b/recipes/linux-hotplug/linux-hotplug-20040920/usb-storage
@@ -0,0 +1,2 @@
+#!/bin/sh
+modprobe sd_mod \ No newline at end of file
diff --git a/recipes/linux-hotplug/linux-hotplug-20040920/usbrc-busybox.patch b/recipes/linux-hotplug/linux-hotplug-20040920/usbrc-busybox.patch
new file mode 100644
index 0000000000..35f43dc52b
--- /dev/null
+++ b/recipes/linux-hotplug/linux-hotplug-20040920/usbrc-busybox.patch
@@ -0,0 +1,13 @@
+--- hotplug/etc/hotplug/usb.rc.old 2005-05-25 15:50:11.000000000 +0100
++++ hotplug/etc/hotplug/usb.rc 2005-05-25 15:50:59.000000000 +0100
+@@ -95,8 +95,8 @@
+ PRODUCT="$(cat $devlink/../idVendor)/$(cat $devlink/../idProduct)/$(cat $devlink/../bcdDevice)"
+ if [ -f $devlink/../../devnum ]
+ then
+- devbus=$( ( echo -n 000 ; cat $devlink/../../devnum ) | grep -o ...\$ )
+- devdev=$( ( echo -n 000 ; cat $devlink/../devnum ) | grep -o ...\$ )
++ devbus=$( ( echo -n 000 ; cat $devlink/../../devnum ) | sed 's/.*\(...\)$/\1/' )
++ devdev=$( ( echo -n 000 ; cat $devlink/../devnum ) | sed 's/.*\(...\)$/\1/' )
+ DEVICE="/proc/bus/usb/$devbus/$devdev"
+ else
+ DEVICE=
diff --git a/recipes/linux-hotplug/linux-hotplug-20040920/userspecified_hcd.patch b/recipes/linux-hotplug/linux-hotplug-20040920/userspecified_hcd.patch
new file mode 100644
index 0000000000..c2ceeb686e
--- /dev/null
+++ b/recipes/linux-hotplug/linux-hotplug-20040920/userspecified_hcd.patch
@@ -0,0 +1,55 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- hotplug-2004_09_20/etc/hotplug/usb.rc~userspecified_hcd.patch
++++ hotplug-2004_09_20/etc/hotplug/usb.rc
+@@ -24,6 +24,7 @@
+ unset I_WANT_A_BROKEN_PS
+ PS_PERSONALITY=linux
+
++HCD=
+ STATIC_MODULE_LIST=
+ X11_USBMICE_HACK=false
+
+@@ -166,20 +167,25 @@
+ # FIXME: some of this should be driven by PCI hotplugging, and have
+ # the blacklist control which uhci driver gets used (before 2.5).
+
+- # "new style" HCDs ... more common code
+- modprobe -q ehci-hcd >/dev/null 2>&1
+- modprobe -q ohci-hcd >/dev/null 2>&1
+- modprobe -q uhci-hcd >/dev/null 2>&1
+-
+- # "old style" HCDs ... more driver-specific bugs
+- modprobe -q usb-ohci >/dev/null 2>&1
+- # NOTE: this prefers "uhci"; you may prefer "usb-uhci".
+- # modprobe -q usb-uhci >/dev/null 2>&1 || modprobe -q uhci >/dev/null 2>&1
+- modprobe -q uhci >/dev/null 2>&1 || modprobe -q usb-uhci >/dev/null 2>&1
+-
+- # ... add any non-PCI HCDS here. Examples include the
+- # CRIS usb-host, Philips ISP-1161, Symlogic 811HS, and so on.
+- # ohci-hcd can handle some non-pci variants.
++ # If the user specified which HCD they want, trust them.
++ if [ -n "$HCD" ]; then
++ modprobe -q $HCD >/dev/null 2>&1
++ else
++ # "new style" HCDs ... more common code
++ modprobe -q ehci-hcd >/dev/null 2>&1
++ modprobe -q ohci-hcd >/dev/null 2>&1
++ modprobe -q uhci-hcd >/dev/null 2>&1
++
++ # "old style" HCDs ... more driver-specific bugs
++ modprobe -q usb-ohci >/dev/null 2>&1
++ # NOTE: this prefers "uhci"; you may prefer "usb-uhci".
++ # modprobe -q usb-uhci >/dev/null 2>&1 || modprobe -q uhci >/dev/null 2>&1
++ modprobe -q uhci >/dev/null 2>&1 || modprobe -q usb-uhci >/dev/null 2>&1
++
++ # ... add any non-PCI HCDS here. Examples include the
++ # CRIS usb-host, Philips ISP-1161, Symlogic 811HS, and so on.
++ # ohci-hcd can handle some non-pci variants.
++ fi
+
+ if [ -d /proc/bus/usb ]; then
+ # If we see there are no busses, we "failed" and