aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux-input/linux-input_cvs.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux-input/linux-input_cvs.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux-input/linux-input_cvs.bb')
-rw-r--r--recipes/linux-input/linux-input_cvs.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/linux-input/linux-input_cvs.bb b/recipes/linux-input/linux-input_cvs.bb
new file mode 100644
index 0000000000..d90322356c
--- /dev/null
+++ b/recipes/linux-input/linux-input_cvs.bb
@@ -0,0 +1,22 @@
+PR = "r2"
+PV = "0.0+cvs${SRCDATE}"
+
+SRC_URI = "cvs://anonymous@linuxconsole.cvs.sourceforge.net/cvsroot/linuxconsole;module=ruby \
+ file://serio.h \
+ file://makefile.patch;patch=1;pnum=0 \
+ file://snes232.patch;patch=1;pnum=0"
+LICENSE = "GPL"
+
+S = "${WORKDIR}/ruby/utils"
+
+CFLAGS =+ "-I. -I../linux/include -I../ruby-2.6/include"
+
+do_configure() {
+ install -d linux
+ install -m 0644 ${WORKDIR}/serio.h linux/
+}
+
+do_install() {
+ install -d ${D}${sbindir}
+ install evtest inputattach jstest jscal fftest ${D}${sbindir}
+}