aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux-libc-headers/linux-libc-headers_2.6.15.99.bb
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-06-21 22:29:35 +0200
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-06-26 10:00:22 +0200
commit96d2cd1ec39a932627dc65580b2a4c10b68de358 (patch)
treeb6f505b30be6abf18a9e82f6272bf15f9508cb7e /recipes/linux-libc-headers/linux-libc-headers_2.6.15.99.bb
parent9e6b31163c44c6b4a306ad5961dda55ee847ffaa (diff)
downloadopenembedded-96d2cd1ec39a932627dc65580b2a4c10b68de358.tar.gz
linux-libc-headers: use kernel-arch.bbclass
linux-libc-headers recipes all have their own code to set ARCH. However this same functionality is in kernel-arch.bbclass This patch adds an inherit kernel-arch in linux-libc-headers.inc and removes all arch calculation code from the recipes Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com> Acked-by: Tom Rini <tom_rini@mentor.com> Acked-by: Chris Larson <chris_larson@mentor.com>
Diffstat (limited to 'recipes/linux-libc-headers/linux-libc-headers_2.6.15.99.bb')
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers_2.6.15.99.bb18
1 files changed, 1 insertions, 17 deletions
diff --git a/recipes/linux-libc-headers/linux-libc-headers_2.6.15.99.bb b/recipes/linux-libc-headers/linux-libc-headers_2.6.15.99.bb
index 3dafb32a08..c5a6c4fccd 100644
--- a/recipes/linux-libc-headers/linux-libc-headers_2.6.15.99.bb
+++ b/recipes/linux-libc-headers/linux-libc-headers_2.6.15.99.bb
@@ -13,7 +13,7 @@ require linux-libc-headers.inc
# since we assume GPL for linux i think we can also assume it here
DEFAULT_PREFERENCE = "-1"
INHIBIT_DEFAULT_DEPS = "1"
-PR = "r6"
+PR = "r7"
SRC_URI = "http://ewi546.ewi.utwente.nl/OE/eabi/linux-libc-headers-${PV}.tar.bz2 \
file://keyboard.patch \
@@ -27,22 +27,6 @@ SRC_URI = "http://ewi546.ewi.utwente.nl/OE/eabi/linux-libc-headers-${PV}.tar.bz2
S = "${WORKDIR}/linux-libc-headers-${PV}"
do_configure () {
- case ${TARGET_ARCH} in
- alpha*) ARCH=alpha ;;
- arm*) ARCH=arm ;;
- cris*) ARCH=cris ;;
- hppa*) ARCH=parisc ;;
- i*86*) ARCH=i386 ;;
- ia64*) ARCH=ia64 ;;
- mips*) ARCH=mips ;;
- m68k*) ARCH=m68k ;;
- powerpc*) ARCH=ppc ;;
- s390*) ARCH=s390 ;;
- sh*) ARCH=sh ;;
- sparc64*) ARCH=sparc64 ;;
- sparc*) ARCH=sparc ;;
- x86_64*) ARCH=x86_64 ;;
- esac
if test ! -e include/asm-$ARCH; then
oefatal unable to create asm symlink in kernel headers
fi