aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux-libc-headers
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-03-24 14:09:21 -0700
committerKhem Raj <raj.khem@gmail.com>2009-03-24 14:09:21 -0700
commita1eb811d0b29ace98d74c2e5f500fc167c059c81 (patch)
tree4202a2269247ca00de125bb07aa51d5463d997ea /recipes/linux-libc-headers
parent0faff8720150863ff38132f87ef65721fcb86dc1 (diff)
downloadopenembedded-a1eb811d0b29ace98d74c2e5f500fc167c059c81.tar.gz
linux-libc-headers_2.6.29.bb: Add 2.6.29 kernel headers recipe.
This kernel headers recipe has few changes compared to old ones. We do not export procinfo.h manually anymore we need to fix the packages which use it to use hwcap.h instead or use something of there own. glibc/arm was one package that relied on it in past but it has been fixed since. If we need to patch glibc then we should backport the patch to 2.6.1
Diffstat (limited to 'recipes/linux-libc-headers')
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers_2.6.29.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes/linux-libc-headers/linux-libc-headers_2.6.29.bb b/recipes/linux-libc-headers/linux-libc-headers_2.6.29.bb
new file mode 100644
index 0000000000..6caddc0c2f
--- /dev/null
+++ b/recipes/linux-libc-headers/linux-libc-headers_2.6.29.bb
@@ -0,0 +1,49 @@
+require linux-libc-headers.inc
+
+INHIBIT_DEFAULT_DEPS = "1"
+DEPENDS += "unifdef-native"
+PR = "r0"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
+ "
+
+S = "${WORKDIR}/linux-${PV}"
+
+set_arch() {
+ case ${TARGET_ARCH} in
+ alpha*) ARCH=alpha ;;
+ arm*) ARCH=arm ;;
+ cris*) ARCH=cris ;;
+ hppa*) ARCH=parisc ;;
+ i*86*) ARCH=i386 ;;
+ ia64*) ARCH=ia64 ;;
+ mips*) ARCH=mips ;;
+ m68k*) ARCH=m68k ;;
+ powerpc*) ARCH=powerpc ;;
+ s390*) ARCH=s390 ;;
+ sh*) ARCH=sh ;;
+ sparc64*) ARCH=sparc64 ;;
+ sparc*) ARCH=sparc ;;
+ x86_64*) ARCH=x86_64 ;;
+ avr32*) ARCH=avr32 ;;
+ bfin*) ARCH=blackfin ;;
+ esac
+}
+
+do_configure() {
+ set_arch
+ oe_runmake allnoconfig ARCH=$ARCH
+}
+
+do_compile () {
+}
+
+do_install() {
+ set_arch
+ oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=$ARCH
+}
+
+do_stage () {
+ set_arch
+ oe_runmake headers_install INSTALL_HDR_PATH=${STAGING_DIR_HOST}${layout_prefix} ARCH=$ARCH
+}