aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux-libc-headers
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-02-07 12:38:24 -0800
committerKhem Raj <raj.khem@gmail.com>2011-02-07 12:39:30 -0800
commit9f1368c60dcef32eb965c0f9ecb81c4adc4f49c5 (patch)
tree14766670098cc59c5e65759f36279d50092b0cba /recipes/linux-libc-headers
parentb2f1e746e90bccbfed0d5bb4dee2688eb1ca22bf (diff)
downloadopenembedded-9f1368c60dcef32eb965c0f9ecb81c4adc4f49c5.tar.gz
linux-libc-headers_2.6.31.bb: Fix build with make 3.82 for powerpc
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/linux-libc-headers')
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers-2.6.31/powerpc-fix-build-with-make-3.82.patch81
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers_2.6.31.bb3
2 files changed, 83 insertions, 1 deletions
diff --git a/recipes/linux-libc-headers/linux-libc-headers-2.6.31/powerpc-fix-build-with-make-3.82.patch b/recipes/linux-libc-headers/linux-libc-headers-2.6.31/powerpc-fix-build-with-make-3.82.patch
new file mode 100644
index 0000000000..1a72dfde1a
--- /dev/null
+++ b/recipes/linux-libc-headers/linux-libc-headers-2.6.31/powerpc-fix-build-with-make-3.82.patch
@@ -0,0 +1,81 @@
+From patchwork Tue Aug 3 06:47:48 2010
+Content-Type: text/plain; charset="utf-8"
+MIME-Version: 1.0
+Content-Transfer-Encoding: 7bit
+Subject: powerpc: fix build with make 3.82
+Date: Mon, 02 Aug 2010 20:47:48 -0000
+From: Sam Ravnborg <sam@ravnborg.org>
+X-Patchwork-Id: 60728
+Message-Id: <20100803064748.GA19193@merkur.ravnborg.org>
+To: Benjamin Herrenschmidt <benh@kernel.crashing.org>,
+ Paul Mackerras <paulus@samba.org>
+Cc: Michal Marek <mmarek@suse.cz>, linuxppc-dev@ozlabs.org,
+ Thomas Backlund <tmb@mandriva.org>
+
+Thomas Backlund reported that the powerpc build broke with make 3.82.
+It failed with the following message:
+
+ arch/powerpc/Makefile:183: *** mixed implicit and normal rules. Stop.
+
+The fix is to avoid mixing non-wildcard and wildcard targets.
+
+Reported-by: Thomas Backlund <tmb@mandriva.org>
+Tested-by: Thomas Backlund <tmb@mandriva.org>
+Cc: Michal Marek <mmarek@suse.cz>
+Cc: stable <stable@kernel.org>
+Signed-off-by: Sam Ravnborg <sam@ravnborg.org>
+
+---
+Hi Ben / Paul.
+
+This fixes powerc build with latest make version.
+The patch is on top of 2.6.35.
+But it is more of a coincidence that we see a make release
+right now and this issue is also present in older kernels.
+So I have added a "Cc: stable <stable@kernel.org>" because
+I consider this relevant for the stable kernel releases too.
+
+@Michal - you got a copy as information only.
+I fear we may see this bug for other parts of the kernel too.
+
+ Sam
+
+
+
+Also corrects the typo uImaged to uImage
+
+-Khem
+
+Index: linux-2.6.31/arch/powerpc/Makefile
+===================================================================
+--- linux-2.6.31.orig/arch/powerpc/Makefile
++++ linux-2.6.31/arch/powerpc/Makefile
+@@ -160,16 +160,24 @@ all: zImage
+
+ CPPFLAGS_vmlinux.lds := -Upowerpc
+
+-BOOT_TARGETS = zImage zImage.initrd uImage zImage% dtbImage% treeImage.% cuImage.% simpleImage.%
++# With make 3.82 we cannot mix normal and wildcard targets
++BOOT_TARGETS1 := zImage zImage.initrd uImage
++BOOT_TARGETS2 := zImage% dtbImage% treeImage.% cuImage.% simpleImage.%
+
+-PHONY += $(BOOT_TARGETS)
++PHONY += $(BOOT_TARGETS1) $(BOOT_TARGETS2)
+
+ boot := arch/$(ARCH)/boot
+
+-$(BOOT_TARGETS): vmlinux
++$(BOOT_TARGETS1): vmlinux
++ $(Q)$(MAKE) ARCH=ppc64 $(build)=$(boot) $(patsubst %,$(boot)/%,$@)
++$(BOOT_TARGETS2): vmlinux
++ $(Q)$(MAKE) ARCH=ppc64 $(build)=$(boot) $(patsubst %,$(boot)/%,$@)
++
++
++bootwrapper_install:
+ $(Q)$(MAKE) ARCH=ppc64 $(build)=$(boot) $(patsubst %,$(boot)/%,$@)
+
+-bootwrapper_install %.dtb:
++%.dtb:
+ $(Q)$(MAKE) ARCH=ppc64 $(build)=$(boot) $(patsubst %,$(boot)/%,$@)
+
+ define archhelp
diff --git a/recipes/linux-libc-headers/linux-libc-headers_2.6.31.bb b/recipes/linux-libc-headers/linux-libc-headers_2.6.31.bb
index c31d48232f..05640db20e 100644
--- a/recipes/linux-libc-headers/linux-libc-headers_2.6.31.bb
+++ b/recipes/linux-libc-headers/linux-libc-headers_2.6.31.bb
@@ -2,12 +2,13 @@ require linux-libc-headers.inc
INHIBIT_DEFAULT_DEPS = "1"
DEPENDS += "unifdef-native"
-PR = "r5"
+PR = "r6"
DEFAULT_PREFERENCE = "-1"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
file://0001-implement-TIF_RESTORE_SIGMASK-support-and-enable-the.patch \
+ file://powerpc-fix-build-with-make-3.82.patch \
"
S = "${WORKDIR}/linux-${PV}"