summaryrefslogtreecommitdiffstats
path: root/recipes/linux-uml/linux-uml-2.4.26/fix-includes.patch
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux-uml/linux-uml-2.4.26/fix-includes.patch
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux-uml/linux-uml-2.4.26/fix-includes.patch')
-rw-r--r--recipes/linux-uml/linux-uml-2.4.26/fix-includes.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/linux-uml/linux-uml-2.4.26/fix-includes.patch b/recipes/linux-uml/linux-uml-2.4.26/fix-includes.patch
new file mode 100644
index 0000000000..a6a0260320
--- /dev/null
+++ b/recipes/linux-uml/linux-uml-2.4.26/fix-includes.patch
@@ -0,0 +1,26 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- linux-2.4.21/arch/um/Makefile~remove-bogus-includes 2004-02-01 15:44:08.000000000 +0100
++++ linux-2.4.21/arch/um/Makefile 2004-02-01 15:51:52.000000000 +0100
+@@ -107,7 +107,7 @@
+ linux: setup $(ARCH_DIR)/main.o vmlinux $(LD_SCRIPT-y)
+ mv vmlinux vmlinux.o
+ $(CC) -Wl,-T,$(LD_SCRIPT-y) $(LINK-y) $(LINK_WRAPS) \
+- -o linux $(ARCH_DIR)/main.o vmlinux.o -L/usr/lib -lutil
++ -o linux $(ARCH_DIR)/main.o vmlinux.o -L$(STAGING_LIBDIR) -lutil
+
+ USER_CFLAGS := $(patsubst -I%,,$(CFLAGS))
+ USER_CFLAGS := $(patsubst -Derrno=kernel_errno,,$(USER_CFLAGS))
+--- linux-2.4.21/arch/um/kernel/tt/Makefile~remove-bogus-includes 2004-02-01 15:44:08.000000000 +0100
++++ linux-2.4.21/arch/um/kernel/tt/Makefile 2004-02-01 15:51:39.000000000 +0100
+@@ -34,6 +34,6 @@
+ $(CC) $(UNMAP_CFLAGS) -c -o $@ $<
+
+ unmap_fin.o : unmap.o
+- ld -r -o $@ $< -lc -L/usr/lib
++ ld -r -o $@ $< -lc -L$(STAGING_LIBDIR)
+
+ clean :