aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/chumby-kernel
diff options
context:
space:
mode:
authorGuo Hongruan <camelguo@gmail.com>2010-01-31 23:10:18 +0000
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2010-02-01 11:00:35 +0100
commit4b35cb7db9c3d65374703c7543bf5394a51f64d9 (patch)
treebe4e7bc6ebfbab206f019212d58e0ee4d9b21710 /recipes/linux/chumby-kernel
parent00af88c464b1de804d55b81a878431913aa752c7 (diff)
downloadopenembedded-4b35cb7db9c3d65374703c7543bf5394a51f64d9.tar.gz
chumby-kernel: add a patch to remove hard setting CROSS_COMPILE from Makefile
* linux-2.6.16-chumby-1.2.tar.gz set CROSS_COMPILE as arm-linux- hardly. * It causes the AR used to compile chumby-kernel is arm-linux-, but it should be set dynamically * according CROSS_COMPILE passed by openembedded Signed-off-by: Guo Hongruan <camelguo@gmail.com> Acked-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
Diffstat (limited to 'recipes/linux/chumby-kernel')
-rw-r--r--recipes/linux/chumby-kernel/Makefile-remove-hard-setting-CROSS_COMPILE.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/linux/chumby-kernel/Makefile-remove-hard-setting-CROSS_COMPILE.patch b/recipes/linux/chumby-kernel/Makefile-remove-hard-setting-CROSS_COMPILE.patch
new file mode 100644
index 0000000000..9a0be9a6b3
--- /dev/null
+++ b/recipes/linux/chumby-kernel/Makefile-remove-hard-setting-CROSS_COMPILE.patch
@@ -0,0 +1,18 @@
+Makefile: remove hard setting CROSS_COMPILE
+
+* linux-2.6.16-chumby-1.2.tar.gz set CROSS_COMPILE as arm-linux- hardly
+* It causes the AR used to compiling linux kernel is arm-linux-ar, which doesn't exist in openembedded at all
+Index: linux-2.6.16/Makefile
+===================================================================
+--- linux-2.6.16.orig/Makefile 2010-02-01 16:19:36.000000000 +0800
++++ linux-2.6.16/Makefile 2010-02-01 16:20:02.000000000 +0800
+@@ -173,8 +173,7 @@
+ # Note: Some architectures assign CROSS_COMPILE in their arch/*/Makefile
+
+ ARCH ?= $(SUBARCH)
+-#CROSS_COMPILE ?=
+-CROSS_COMPILE = arm-linux-
++CROSS_COMPILE ?=
+
+ # Architecture as present in compile.h
+ UTS_MACHINE := $(ARCH)