aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/devkitidp-pxa255_2.6.19.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux/devkitidp-pxa255_2.6.19.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/devkitidp-pxa255_2.6.19.bb')
-rw-r--r--recipes/linux/devkitidp-pxa255_2.6.19.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/linux/devkitidp-pxa255_2.6.19.bb b/recipes/linux/devkitidp-pxa255_2.6.19.bb
new file mode 100644
index 0000000000..f9eb6a7777
--- /dev/null
+++ b/recipes/linux/devkitidp-pxa255_2.6.19.bb
@@ -0,0 +1,30 @@
+SECTION = "kernel"
+DESCRIPTION = "Linux kernel for the BSQUARE PXA255 DevKitIDP"
+LICENSE = "GPL"
+PR = "r4"
+DEPENDS = "u-boot"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.19.tar.bz2 \
+ file://linux-2.6.19_devkitidp1.patch;patch=1 \
+ file://defconfig"
+
+S = "${WORKDIR}/linux-2.6.19"
+
+COMPATIBLE_MACHINE = "devkitidp-pxa255"
+
+inherit kernel
+inherit package
+
+ARCH = "arm"
+KERNEL_IMAGETYPE = "uImage"
+#CMDLINE_CONSOLE ?= "ttyS0,115200n8"
+#CMDLINE_ROOT = "root=/dev/slug rootfstype=ext2,jffs2 initrd=0x01000000,10M mem=32M@0x00000000"
+#CMDLINE_ROOT = "root=/dev/mtdblock4 rootfstype=jffs2 mem=32M@0x00000000"
+#CMDLINE_ROOT = "root=/dev/ram0 rw rootfstype=ext2,jffs2 initrd=0x01000000,10M init=/linuxrc mem=32M@0x00000000"
+#CMDLINE = "${CMDLINE_ROOT} ${CMDLINE_CONSOLE}"
+CMDLINE = "root=/dev/mtdblock2 rootfstype=jffs2 console=ttyS0,115200 mtdparts=phys_mapped_flash:256k(boot)ro,0x1C0000(kernel),-(root)"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+# echo "CONFIG_CMDLINE=\"${CMDLINE}\"" >> ${S}/.config
+}