aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/gumstix_2.6.5-gnalm1-gum0.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux/gumstix_2.6.5-gnalm1-gum0.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/gumstix_2.6.5-gnalm1-gum0.bb')
-rw-r--r--recipes/linux/gumstix_2.6.5-gnalm1-gum0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/linux/gumstix_2.6.5-gnalm1-gum0.bb b/recipes/linux/gumstix_2.6.5-gnalm1-gum0.bb
new file mode 100644
index 0000000000..9af2696d66
--- /dev/null
+++ b/recipes/linux/gumstix_2.6.5-gnalm1-gum0.bb
@@ -0,0 +1,25 @@
+BROKEN = "1"
+#linux-2.6.5-gnalm1-gum0.patch is not fetchable
+
+SECTION = "kernel"
+DESCRIPTION = "Linux kernel for OMAP processors"
+LICENSE = "GPL"
+
+COMPATIBLE_MACHINE = "gumstix"
+
+# NOTE: pulled local linux-2.6.5-gnalm1, since it didn't apply cleanly
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.5.tar.bz2 \
+ file://linux-2.6.5-gnalm1.patch;patch=1 \
+ http://gumstix.superlucidity.net/downloads/kernel/patches/linux-2.6.5-gnalm1-gum0.patch;patch=1 \
+ file://defconfig"
+S = "${WORKDIR}/linux-2.6.5"
+
+inherit kernel
+
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config || die "no default configuration for ${MACHINE} available."
+ oe_runmake oldconfig
+}
+
+COMPATIBLE_HOST = 'arm.*-linux'