aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-2.6.31/pcm043/0027-imx-ssi-flush-fifos.patch
diff options
context:
space:
mode:
authorJan Kobler <eng1@koblersystems.de>2011-03-01 14:01:38 +0100
committerTom Rini <tom_rini@mentor.com>2011-03-01 11:26:09 -0700
commit1840fd720b423ed4245a4fdb511170ae33dfde80 (patch)
tree92ec149ed37bf1981debf236649546c96c1024e4 /recipes/linux/linux-2.6.31/pcm043/0027-imx-ssi-flush-fifos.patch
parentaffc152bd4df73fd3892eb09cab0a331fd282866 (diff)
downloadopenembedded-1840fd720b423ed4245a4fdb511170ae33dfde80.tar.gz
linux-2.6.31 config and patch files for pcm043
These config and patch files are from the Phytec Linux BSP for phyCORE-i.MX35 PD10.1.1. They were taken from the archive ftp://ftp.phytec.de/pub/Products/phyCORE-iMX350/Linux/PD10.1.1/OSELAS.BSP-Phytec-phyCORE-i.MX35-PD10.1.1.tar.gz The patch files are from the folder in this archive OSELAS.BSP-Phytec-phyCORE-i.MX35-PD10.1.1/configs/phyCORE-i.MX35-2010.08.0/patches/linux-2.6.31.6/generic The patch files have been shipped for linux-2.6.31.6 and are used here on linux-2.6.31.12. Because it seems to work, pcm043 is added to linux-2.6.31.bb. The sequence of the patches for pcm043 in linux-2.6.31.bb is derived from the file OSELAS.BSP-Phytec-phyCORE-i.MX35-PD10.1.1/configs/phyCORE-i.MX35-2010.08.0/patches/linux-2.6.31.6/generic/series The defconfig file is the file OSELAS.BSP-Phytec-phyCORE-i.MX35-PD10.1.1/configs/phyCORE-i.MX35-2010.08.0/kernelconfig These patch files from the folder OSELAS.BSP-Phytec-phyCORE-i.MX35-PD10.1.1/configs/phyCORE-i.MX35-2010.08.0/patches/linux-2.6.31.6/generic are NOT used: 0063-add-generic-platform-bus-based-sja1000-driver.patch 0076-mx3fb-pretty-printing-update.patch 0078-sja1000-driver-Fix-net-device-stats.patch patch-2.6.31.6-rt19.gz because they are not referenced by the file OSELAS.BSP-Phytec-phyCORE-i.MX35-PD10.1.1/configs/phyCORE-i.MX35-2010.08.0/patches/linux-2.6.31.6/generic/series Signed-off-by: Jan Kobler <eng1@koblersystems.de> Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/linux/linux-2.6.31/pcm043/0027-imx-ssi-flush-fifos.patch')
-rw-r--r--recipes/linux/linux-2.6.31/pcm043/0027-imx-ssi-flush-fifos.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/linux/linux-2.6.31/pcm043/0027-imx-ssi-flush-fifos.patch b/recipes/linux/linux-2.6.31/pcm043/0027-imx-ssi-flush-fifos.patch
new file mode 100644
index 0000000000..56fcd9e6f1
--- /dev/null
+++ b/recipes/linux/linux-2.6.31/pcm043/0027-imx-ssi-flush-fifos.patch
@@ -0,0 +1,29 @@
+From 447b943dc48d3775e59be1800a3198f65265536d Mon Sep 17 00:00:00 2001
+From: Sascha Hauer <s.hauer@pengutronix.de>
+Date: Wed, 2 Dec 2009 11:59:05 +0100
+Subject: [PATCH 27/28] imx-ssi: flush fifos
+
+Signed-off-by: Sascha Hauer <s.hauer@pengutronix.de>
+---
+ sound/soc/imx/imx-ssi.c | 5 +++++
+ 1 files changed, 5 insertions(+), 0 deletions(-)
+
+diff --git a/sound/soc/imx/imx-ssi.c b/sound/soc/imx/imx-ssi.c
+index 6219df9..d25ee2b 100644
+--- a/sound/soc/imx/imx-ssi.c
++++ b/sound/soc/imx/imx-ssi.c
+@@ -333,6 +333,11 @@ static int imx_ssi_trigger(struct snd_pcm_substream *substream, int cmd,
+ /* rx/tx are always enabled to access ac97 registers */
+ writel(scr, ssi->base + SSI_SCR);
+
++ if (substream->stream == SNDRV_PCM_STREAM_PLAYBACK)
++ writel(SSI_SOR_TX_CLR, ssi->base + SSI_SOR);
++ else
++ writel(SSI_SOR_RX_CLR, ssi->base + SSI_SOR);
++
+ writel(sier, ssi->base + SSI_SIER);
+
+ return 0;
+--
+1.6.5.2
+