aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-2.6.31
diff options
context:
space:
mode:
authorOE Builder <oebuilder@waffle.bolloretelecom.eu>2009-10-30 14:48:22 +0100
committerOE Builder <oebuilder@waffle.bolloretelecom.eu>2009-10-30 14:48:22 +0100
commitf8cfca44d691659003e92605f2f2a2549139edb8 (patch)
treee240634dc2668055660457a6fe1b55113dc94d92 /recipes/linux/linux-2.6.31
parent7cfed4fa3768dc37a4649b654d0fec8953c62001 (diff)
downloadopenembedded-f8cfca44d691659003e92605f2f2a2549139edb8.tar.gz
linux-2.6.31: fix GPIO keys for boc01
Diffstat (limited to 'recipes/linux/linux-2.6.31')
-rw-r--r--recipes/linux/linux-2.6.31/boc01/014-091030-buttons.patch16
-rw-r--r--recipes/linux/linux-2.6.31/boc01/defconfig4
2 files changed, 11 insertions, 9 deletions
diff --git a/recipes/linux/linux-2.6.31/boc01/014-091030-buttons.patch b/recipes/linux/linux-2.6.31/boc01/014-091030-buttons.patch
index c589a47086..6b2dba1337 100644
--- a/recipes/linux/linux-2.6.31/boc01/014-091030-buttons.patch
+++ b/recipes/linux/linux-2.6.31/boc01/014-091030-buttons.patch
@@ -1,7 +1,7 @@
Index: linux-2.6.31/drivers/input/misc/Kconfig
===================================================================
---- linux-2.6.31.orig/drivers/input/misc/Kconfig 2009-10-30 13:52:02.000000000 +0100
-+++ linux-2.6.31/drivers/input/misc/Kconfig 2009-10-30 13:52:02.000000000 +0100
+--- linux-2.6.31.orig/drivers/input/misc/Kconfig 2009-10-30 14:22:53.000000000 +0100
++++ linux-2.6.31/drivers/input/misc/Kconfig 2009-10-30 14:22:53.000000000 +0100
@@ -270,6 +270,13 @@
To compile this driver as a module, choose M here: the
module will be called dm355evm_keys.
@@ -18,8 +18,8 @@ Index: linux-2.6.31/drivers/input/misc/Kconfig
select INPUT_POLLDEV
Index: linux-2.6.31/drivers/input/misc/Makefile
===================================================================
---- linux-2.6.31.orig/drivers/input/misc/Makefile 2009-10-30 13:52:02.000000000 +0100
-+++ linux-2.6.31/drivers/input/misc/Makefile 2009-10-30 13:52:02.000000000 +0100
+--- linux-2.6.31.orig/drivers/input/misc/Makefile 2009-10-30 14:22:53.000000000 +0100
++++ linux-2.6.31/drivers/input/misc/Makefile 2009-10-30 14:22:53.000000000 +0100
@@ -26,4 +26,5 @@
obj-$(CONFIG_INPUT_UINPUT) += uinput.o
obj-$(CONFIG_INPUT_WISTRON_BTNS) += wistron_btns.o
@@ -29,8 +29,8 @@ Index: linux-2.6.31/drivers/input/misc/Makefile
Index: linux-2.6.31/drivers/input/misc/boc-btns.c
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.31/drivers/input/misc/boc-btns.c 2009-10-30 13:52:26.000000000 +0100
-@@ -0,0 +1,209 @@
++++ linux-2.6.31/drivers/input/misc/boc-btns.c 2009-10-30 14:24:42.000000000 +0100
+@@ -0,0 +1,211 @@
+/*
+ * Buttons for BoC
+ *
@@ -94,7 +94,9 @@ Index: linux-2.6.31/drivers/input/misc/boc-btns.c
+ // read GPIO
+ for (i = 0; i < ARRAY_SIZE(input_keymap); i++)
+ {
-+ value = gpio_get_value(input_buttons[i].gpio) ^ input_buttons[i].active_low;
++ value = gpio_get_value(input_buttons[i].gpio) ? 1 : 0;
++ if (input_buttons[i].active_low)
++ value = !value;
+ if (value != bdev->state[i])
+ {
+ input_event(input, EV_MSC, MSC_SCAN, i);
diff --git a/recipes/linux/linux-2.6.31/boc01/defconfig b/recipes/linux/linux-2.6.31/boc01/defconfig
index 56e10a04a0..ae2b9b510e 100644
--- a/recipes/linux/linux-2.6.31/boc01/defconfig
+++ b/recipes/linux/linux-2.6.31/boc01/defconfig
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
# Linux kernel version: 2.6.31.3
-# Wed Oct 28 11:48:05 2009
+# Fri Oct 30 14:31:19 2009
#
# CONFIG_PPC64 is not set
@@ -1061,7 +1061,7 @@ CONFIG_INPUT_POLLDEV=y
# CONFIG_INPUT_MOUSEDEV is not set
# CONFIG_INPUT_JOYDEV is not set
CONFIG_INPUT_EVDEV=y
-CONFIG_INPUT_EVBUG=y
+# CONFIG_INPUT_EVBUG is not set
#
# Input Device Drivers