aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-amsdelta-2.6_2.6.16-omap2.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux/linux-amsdelta-2.6_2.6.16-omap2.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/linux-amsdelta-2.6_2.6.16-omap2.bb')
-rw-r--r--recipes/linux/linux-amsdelta-2.6_2.6.16-omap2.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/linux/linux-amsdelta-2.6_2.6.16-omap2.bb b/recipes/linux/linux-amsdelta-2.6_2.6.16-omap2.bb
new file mode 100644
index 0000000000..db72fe7d31
--- /dev/null
+++ b/recipes/linux/linux-amsdelta-2.6_2.6.16-omap2.bb
@@ -0,0 +1,34 @@
+SECTION = "kernel"
+DESCRIPTION = "2.6 Linux kernel for the Amstrad Delta (E3)"
+LICENSE = "GPL"
+
+COMPATIBLE_MACHINE = "amsdelta"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.16.tar.bz2 \
+ http://www.muru.com/linux/omap/patches/patch-2.6.16-omap2.bz2;patch=1 \
+ http://the.earth.li/pub/e3/2.6.16/00-ams-delta-backlight.diff;patch=1 \
+ http://the.earth.li/pub/e3/2.6.16/01-ams-delta-lcd.diff;patch=1 \
+ http://the.earth.li/pub/e3/2.6.16/02-ams-delta-keypad.diff;patch=1 \
+ http://the.earth.li/pub/e3/2.6.16/03-ams-delta-modem.diff;patch=1 \
+ http://the.earth.li/pub/e3/2.6.16/04-omapfb-12bpp-support.diff;patch=1 \
+ http://the.earth.li/pub/e3/2.6.16/05-ams-delta-nand.diff;patch=1 \
+ http://the.earth.li/pub/e3/2.6.16/06-ams-delta-keyboard.diff;patch=1 \
+ http://the.earth.li/pub/e3/2.6.16/08-ams-delta-sound.diff;patch=1 \
+ file://defconfig"
+S = "${WORKDIR}/linux-2.6.16"
+
+inherit kernel
+
+python __anonymous () {
+ import re
+ host = bb.data.getVar('HOST_SYS', d, 1)
+ if not re.match('arm.*-linux', host):
+ raise bb.parse.SkipPackage("incompatible with host %s" % host)
+}
+
+KERNEL_IMAGETYPE = "uImage"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+ oe_runmake oldconfig
+}