aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-bast_2.4.25-vrs1-bast1.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux/linux-bast_2.4.25-vrs1-bast1.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/linux-bast_2.4.25-vrs1-bast1.bb')
-rw-r--r--recipes/linux/linux-bast_2.4.25-vrs1-bast1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/linux/linux-bast_2.4.25-vrs1-bast1.bb b/recipes/linux/linux-bast_2.4.25-vrs1-bast1.bb
new file mode 100644
index 0000000000..2fbdf1aa9c
--- /dev/null
+++ b/recipes/linux/linux-bast_2.4.25-vrs1-bast1.bb
@@ -0,0 +1,22 @@
+SECTION = "kernel"
+DESCRIPTION = "Linux kernel for Simtec EB2410ITX"
+LICENSE = "GPL"
+KV = "2.4.25"
+
+KERNEL_CCSUFFIX = "-3.3.3"
+COMPATIBLE_HOST = "arm.*-linux"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.4/linux-${KV}.tar.bz2 \
+ ftp://ftp.arm.linux.org.uk/pub/armlinux/source/kernel-patches/v2.4/patch-2.4.25-vrs1.bz2;patch=1 \
+ http://www.simtec.co.uk/products/SWLINUX/files/patch-2.4.25-vrs1-bast1.bz2;patch=1 \
+ file://defconfig \
+ file://mkdep.patch;patch=1 \
+ file://defconfig"
+S = "${WORKDIR}/linux-${KV}"
+
+inherit kernel
+
+
+do_configure_prepend() {
+ cp ${WORKDIR}/defconfig ${S}/.config
+}