aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-bug_2.6.27.2.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin@buglabs.net>2009-04-23 13:04:00 +0200
committerMarcin Juszkiewicz <marcin@buglabs.net>2009-04-23 20:11:58 +0200
commitb5b0c248016cd2df15ec33a7344e3b8fef317061 (patch)
tree2d3837ddc831de3886ba3314858b789ededf3b03 /recipes/linux/linux-bug_2.6.27.2.bb
parent92e83440eb4149db23159fd0dd3cf32262e0d169 (diff)
downloadopenembedded-b5b0c248016cd2df15ec33a7344e3b8fef317061.tar.gz
linux-bug: added 2.6.27.2 from BUG Labs svn
By default r8918 is used - can be overriden in local.conf by: SRCREV_pn-linux-bug = "${AUTOREV}" In BUG Linux we used AUTOREV by default.
Diffstat (limited to 'recipes/linux/linux-bug_2.6.27.2.bb')
-rw-r--r--recipes/linux/linux-bug_2.6.27.2.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes/linux/linux-bug_2.6.27.2.bb b/recipes/linux/linux-bug_2.6.27.2.bb
new file mode 100644
index 0000000000..db49e63993
--- /dev/null
+++ b/recipes/linux/linux-bug_2.6.27.2.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "Linux kernel for bug"
+
+PV_append = "+svnr${SRCREV}"
+KV = "2.6.27.2"
+PR = "r26"
+
+COMPATIBLE_MACHINE = "bug"
+
+SVN_PRJ = "bug-linux-${KV}"
+
+SRC_URI = "svn://svn.buglabs.net/bug/trunk;module=${SVN_PRJ};proto=svn \
+ file://defconfig \
+ "
+
+S = "${WORKDIR}/${SVN_PRJ}"
+
+ARM_KEEP_OABI ?= "0"
+UBOOT_ENTRYPOINT = "0x80008000"
+
+require linux.inc
+
+do_install_append() {
+# install -m 0644 arch/${ARCH}/boot/uImage ${D}/${KERNEL_IMAGEDEST}/uImage-${KERNEL_VERSION}
+ cd ${D}/${KERNEL_IMAGEDEST} && ln -sf uImage-${KERNEL_VERSION} uImage
+}
+
+FILESDIR = "${WORKDIR}"
+FILES_kernel-image += "${KERNEL_IMAGEDEST}/uImage*"
+
+module_conf_g_ether = "options g_ether host_addr=46:0d:9e:67:69:eb"
+module_conf_bmi_audio = "options bmi_audio output_ints=1"
+module_autoload_arcotg_udc = "arcotg_udc"
+module_autoload_ehci-hcd = "ehci-hcd"
+module_autoload_g_ether = "g_ether"
+module_autoload_bugnav = "bugnav"
+module_autoload_bug_audio = "bug_audio"
+module_autoload_bugpm = "bugpm"
+module_autoload_bugpm_apm = "bugpm_apm"
+module_autoload_rtc-isl12026 = "rtc-isl12026"
+module_autoload_bug_v4l2_capture = "bug_v4l2_capture"
+# bmi_lcd_core loaded to ensure xserver device nodes are created on boot.
+module_autoload_bmi_lcd_core = "bmi_lcd_core"