aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-colinux_2.4.28.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux/linux-colinux_2.4.28.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/linux-colinux_2.4.28.bb')
-rw-r--r--recipes/linux/linux-colinux_2.4.28.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/linux/linux-colinux_2.4.28.bb b/recipes/linux/linux-colinux_2.4.28.bb
new file mode 100644
index 0000000000..dc052afce1
--- /dev/null
+++ b/recipes/linux/linux-colinux_2.4.28.bb
@@ -0,0 +1,29 @@
+SECTION = "kernel"
+DESCRIPTION = "User Mode Linux Kernel"
+LICENSE = "GPL"
+COLV = "0.6.1"
+
+COMPATIBLE_MACHINE = "colinux"
+
+#http://internap.dl.sourceforge.net/sourceforge/colinux/coLinux-0.6.1.tar.gz
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.4/linux-${PV}.tar.bz2 \
+ file://colinux-${COLV}.patch;patch=1 \
+ file://nofpu.patch;patch=1 \
+ file://shortloadbytes.patch;patch=1 \
+ file://gcc-registerparanoia.patch;patch=1 \
+ file://linux-2.4.24-attribute-used.patch;patch=1 \
+ file://gcc340-fixes-v2.4.26-try3.patch;patch=1 \
+ file://defconfig"
+
+S = "${WORKDIR}/linux-${PV}"
+
+inherit kernel
+
+COMPATIBLE_HOST = "i.86.*-linux"
+KERNEL_IMAGETYPE = "vmlinux"
+KERNEL_OUTPUT = "./${KERNEL_IMAGETYPE}"
+
+do_configure() {
+ install -m 0644 ${WORKDIR}/defconfig .config
+ kernel_do_configure
+}