aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-davinci_git.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux/linux-davinci_git.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/linux-davinci_git.bb')
-rw-r--r--recipes/linux/linux-davinci_git.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes/linux/linux-davinci_git.bb b/recipes/linux/linux-davinci_git.bb
new file mode 100644
index 0000000000..3d88995f6f
--- /dev/null
+++ b/recipes/linux/linux-davinci_git.bb
@@ -0,0 +1,38 @@
+require linux.inc
+
+DESCRIPTION = "Linux kernel for Davinci processors"
+KERNEL_IMAGETYPE = "uImage"
+
+COMPATIBLE_MACHINE = "(davinci-dvevm|davinci-sffsdr|dm355-leopard)"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRCREV = "486afa37130356662213cc1a2199a285b4fd72af"
+
+PV = "2.6.29+2.6.29-rc7-${PR}+gitr${SRCREV}"
+PR = "r1"
+
+SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/khilman/linux-davinci.git;protocol=git \
+ file://update-mach-types.patch;patch=1 \
+ file://defconfig"
+
+SRC_URI_append_davinci-sffsdr = " \
+ file://0001-USB-musb-cppi-bugfixes.patch;patch=1 \
+ file://0002-ARM-Mark-unsupported-syscalls-as-IGNORE.patch;patch=1 \
+ file://0003-Add-macros-for-enabling-a-UART.patch;patch=1 \
+ file://0004-Davinci-Enable-MAC-address-to-be-specified-on-kerne.patch;patch=1 \
+ file://0005-Add-DAS-Mini-DAS-and-AFE-USB-machine-types.patch;patch=1 \
+ file://0006-ALSA-ASoC-DaVinci-Fix-SFFSDR-compilation-error.patch;patch=1 \
+ file://0007-ALSA-ASoC-Davinci-Fix-SFFSDR-FPGA-module-codec-FS.patch;patch=1 \
+ file://0008-ALSA-ASoC-Davinci-Fix-incorrect-machine-type-for.patch;patch=1 \
+ file://0009-sound-ASoC-Fix-DaVinci-module-unload-error.patch;patch=1 \
+ file://0010-Add-generic-FPGA-bitstream-loader-driver.patch;patch=1 \
+ file://0011-Add-lyrvpss-example-driver-for-the-SFFSDR-board.patch;patch=1 \
+ file://0012-Update-SFFSDR-to-support-FPGA-and-lyrvpss-drivers.patch;patch=1 \
+ "
+
+SRC_URI_append_dm355-leopard = " \
+ file://0001-dm355-leopard-add-board-file-based-on-board-dm355-e.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/git"