aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-davinci_git.bb
diff options
context:
space:
mode:
authorKoen Kooi <k-kooi@ti.com>2009-11-16 10:17:24 +0100
committerKoen Kooi <koen@openembedded.org>2009-12-04 19:46:02 +0100
commitb788499815bfc1974d4277c0a261b9a7c24aa816 (patch)
tree6c0546c0891d884f835355d851ec07147165ddd2 /recipes/linux/linux-davinci_git.bb
parent08dcecdc77ceb6a3673605216493905859f11982 (diff)
downloadopenembedded-b788499815bfc1974d4277c0a261b9a7c24aa816.tar.gz
recipes/ti: merge in updates
* New codec recipes from Arago team in Germantown * Updated dm6446 and dm355 from Brijesh Singh * cmem, gst-ti and dmai fixes from Brijesh Singh angstrom: introduce SOC_FAMILY and start using it TI recipes as a testing ground * SOC_FAMILY tells you which system on chip is used in the MACHINE, e.g. omap3, dm355, pxa25x, s3c24xx. This avoids having to duplicate lots of overrides in machine specific recipes. This is *NOT* intended to be used as a package arch.
Diffstat (limited to 'recipes/linux/linux-davinci_git.bb')
-rw-r--r--recipes/linux/linux-davinci_git.bb43
1 files changed, 19 insertions, 24 deletions
diff --git a/recipes/linux/linux-davinci_git.bb b/recipes/linux/linux-davinci_git.bb
index f99f8ae937..05b8eba45e 100644
--- a/recipes/linux/linux-davinci_git.bb
+++ b/recipes/linux/linux-davinci_git.bb
@@ -8,8 +8,7 @@ COMPATIBLE_MACHINE = "(dm355-evm|dm365-evm|dm6446-evm|dm6467-evm|dm6467t-evm|da8
DEFAULT_PREFERENCE = "1"
BRANCH = "master"
-
-# DAVINCI
+SRC_URI = "file://defconfig "
# dm355-evm/dm365-evm/dm6446-evm/dm6467-evm/dm6467t-evm Davinci PSP.03.01.00.28 (Phase 3 Build r28)
SRCREV_dm355-evm = "7b2683fd0168df1576fcea947ef9f63e905de807"
@@ -25,38 +24,34 @@ PV_dm6446-evm = "2.6.31+2.6.32-rc2-${PR}+gitr${SRCREV}"
PV_dm6467-evm = "2.6.31+2.6.32-rc2-${PR}+gitr${SRCREV}"
PV_dm6467t-evm = "2.6.31+2.6.32-rc2-${PR}+gitr${SRCREV}"
-SRC_URI_dm355-evm = "git://arago-project.org/git/projects/linux-davinci.git;protocol=git \
- file://defconfig"
-SRC_URI_dm365-evm = "git://arago-project.org/git/projects/linux-davinci.git;protocol=git \
- file://defconfig"
-SRC_URI_dm6446-evm = "git://arago-project.org/git/projects/linux-davinci.git;protocol=git \
- file://defconfig"
-SRC_URI_dm6467-evm = "git://arago-project.org/git/projects/linux-davinci.git;protocol=git \
- file://defconfig"
-SRC_URI_dm6467t-evm = "git://arago-project.org/git/projects/linux-davinci.git;protocol=git \
- file://defconfig"
+BRANCH_dm355-evm = "r28"
+BRANCH_dm365-evm = "r28"
+BRANCH_dm6446-evm = "r28"
+BRANCH_dm6467-evm = "r28"
+BRANCH_dm6467t-evm = "r28"
+
+SRC_URI_append_dm355-evm = "git://arago-project.org/git/projects/linux-davinci.git;protocol=git;branch=${BRANCH}"
+SRC_URI_append_dm365-evm = "git://arago-project.org/git/projects/linux-davinci.git;protocol=git;branch=${BRANCH}"
+SRC_URI_append_dm6446-evm = "git://arago-project.org/git/projects/linux-davinci.git;protocol=git;branch=${BRANCH}"
+SRC_URI_append_dm6467-evm = "git://arago-project.org/git/projects/linux-davinci.git;protocol=git;branch=${BRANCH}"
+SRC_URI_append_dm6467t-evm = "git://arago-project.org/git/projects/linux-davinci.git;protocol=git;branch=${BRANCH}"
# OMAPL
# da830-omapl137-evm/da850-omapl138-evm/hawkboard OMAPL PSP.3.20.00.07 (Beta)
-SRCREV_da830-omapl137-evm = "b60234a5b0ee985912ecb59d3e689c1ed4baa46c"
-SRCREV_da850-omapl138-evm = "b60234a5b0ee985912ecb59d3e689c1ed4baa46c"
-SRCREV_hawkboard = "b60234a5b0ee985912ecb59d3e689c1ed4baa46c"
+SRCREV_da830-omapl137-evm = "b306b47248ef6b4e5927a6baa2849ff434c12ddb"
+SRCREV_da850-omapl138-evm = "b306b47248ef6b4e5927a6baa2849ff434c12ddb"
+SRCREV_hawkboard = "b306b47248ef6b4e5927a6baa2849ff434c12ddb"
# The main PR is now using MACHINE_KERNEL_PR, for davinci see conf/machine/include/davinci.inc
PV_da830-omapl137-evm = "2.6.31+2.6.32-rc6-${PR}+gitr${SRCREV}"
PV_da850-omapl138-evm = "2.6.31+2.6.32-rc6-${PR}+gitr${SRCREV}"
PV_hawkboard = "2.6.31+2.6.32-rc6-${PR}+gitr${SRCREV}"
-SRC_URI_da830-omapl137-evm = "git://arago-project.org/git/people/sekhar/linux-omapl1.git;protocol=git;branch=${BRANCH} \
- file://defconfig"
-
-SRC_URI_da850-omapl138-evm = "git://arago-project.org/git/people/sekhar/linux-omapl1.git;protocol=git;branch=${BRANCH} \
- file://defconfig"
-
-SRC_URI_hawkboard = "git://arago-project.org/git/people/sekhar/linux-omapl1.git;protocol=git;branch=${BRANCH} \
- file://patch_hawk.diff;patch=1 \
- file://defconfig"
+SRC_URI_append_da830-omapl137-evm = "git://arago-project.org/git/people/sekhar/linux-omapl1.git;protocol=git;branch=${BRANCH}"
+SRC_URI_append_da850-omapl138-evm = "git://arago-project.org/git/people/sekhar/linux-omapl1.git;protocol=git;branch=${BRANCH}"
+SRC_URI_append_hawkboard = "git://arago-project.org/git/people/sekhar/linux-omapl1.git;protocol=git;branch=${BRANCH} \
+ file://patch_hawk.diff;patch=1"
S = "${WORKDIR}/git"