summaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-dht-walnut_2.6.23.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux/linux-dht-walnut_2.6.23.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/linux-dht-walnut_2.6.23.bb')
-rw-r--r--recipes/linux/linux-dht-walnut_2.6.23.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/recipes/linux/linux-dht-walnut_2.6.23.bb b/recipes/linux/linux-dht-walnut_2.6.23.bb
new file mode 100644
index 0000000000..181488190e
--- /dev/null
+++ b/recipes/linux/linux-dht-walnut_2.6.23.bb
@@ -0,0 +1,56 @@
+# Copyright (C) 2007, Stelios Koroneos - Digital OPSiS, All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+require linux.inc
+
+DESCRIPTION = "Linux kernel for DHT-Walnut (ppc) machine"
+
+DEFAULT_PREFERENCE = "-1"
+
+PR = "r0"
+DEPENDS = "u-boot"
+
+COMPATIBLE_MACHINE = "dht-walnut"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
+ file://defconfig"
+
+S = "${WORKDIR}/linux-${PV}"
+
+FILES_kernel-image = "/boot/zImage.elf"
+
+export OS = "Linux"
+ARCH = "ppc"
+
+do_stage_append () {
+#need ppc platforms includes + friends in order for external kernel modules to compile as headers as still split
+
+ install -d ${STAGING_KERNEL_DIR}/arch/
+ cp -pPR arch/ppc ${STAGING_KERNEL_DIR}/arch/
+ cp -pPR arch/powerpc ${STAGING_KERNEL_DIR}/arch/
+
+ cp -pPR include/asm-powerpc ${STAGING_KERNEL_DIR}/include/
+ cp -pPR include/asm-ppc ${STAGING_KERNEL_DIR}/include/
+}
+
+do_install_append () {
+ install -d ${DEPLOY_DIR_IMAGE}
+ if [ -e arch/ppc/boot/images/zImage.elf ] ; then
+ cp -a arch/ppc/boot/images/zImage.elf arch/ppc/boot/images/zImage
+ install -m 0755 arch/ppc/boot/images/zImage.elf \
+ ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}.elf
+ fi
+ install -m 0755 vmlinux ${DEPLOY_DIR_IMAGE}/
+}
+
+
+pkg_postinst_kernel () {
+ true
+}
+
+pkg_postrm_kernel () {
+ true
+}
+
+
+
+