aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-geodegx_2.4.24.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux/linux-geodegx_2.4.24.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/linux-geodegx_2.4.24.bb')
-rw-r--r--recipes/linux/linux-geodegx_2.4.24.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/linux/linux-geodegx_2.4.24.bb b/recipes/linux/linux-geodegx_2.4.24.bb
new file mode 100644
index 0000000000..fb42b562cc
--- /dev/null
+++ b/recipes/linux/linux-geodegx_2.4.24.bb
@@ -0,0 +1,26 @@
+# Linux kernel OE build file for the AMD Geode GX processor
+# Copyright (C) 2005, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+COMPATIBLE_MACHINE = "geodegx"
+
+KV = "2.4.24"
+DESCRIPTION = "Linux kernel for the AMD Geode GX processor"
+LICENSE = "GPL"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.4/linux-${KV}.tar.bz2 \
+ http://www.amd.com/files/connectivitysolutions/geode/Patches_Linux_${KV}_1.00.tar.gz \
+ file://${WORKDIR}/Patches_Linux_${KV}_1.00/linux-${KV}-geode.patch;patch=1 \
+ file://linux-2.4.24-gcc340-fixes.patch;patch=1 \
+ file://defconfig"
+
+S = "${WORKDIR}/linux-${KV}"
+
+inherit kernel
+
+ARCH = "i386"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+ oe_runmake oldconfig
+}