aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-ixp4xx.inc
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux/linux-ixp4xx.inc
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/linux-ixp4xx.inc')
-rw-r--r--recipes/linux/linux-ixp4xx.inc26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/linux/linux-ixp4xx.inc b/recipes/linux/linux-ixp4xx.inc
new file mode 100644
index 0000000000..9c4dd375a0
--- /dev/null
+++ b/recipes/linux/linux-ixp4xx.inc
@@ -0,0 +1,26 @@
+# linux-ixp4xx.inc
+#
+DESCRIPTION = "Linux 2.6.x kernel for IXP4xx devices"
+
+COMPATIBLE_HOST = 'arm.*-linux.*'
+COMPATIBLE_MACHINE = '(ixp4xx|nslu2|syhl1)'
+
+# To specify the console set KERNEL_CONSOLE in the .bb file.
+
+# CMDLINE_ROOT: machine specific boot options - should not be set on a
+# generic kernel!
+CMDLINE_ROOT ?= ""
+
+# CMDLINE_DEBUG: debug options such as noirqdebug, defaults to empty
+# override in local.conf etc
+CMDLINE_DEBUG ?= ""
+
+CMDLINE = "${CMDLINE_ROOT}"
+CMDLINE += "${CMDLINE_DEBUG}"
+CMDLINE += "${CMDLINE_CONSOLE}"
+
+# Kernel module dependencies
+# (according to hrw, these should go in kernel.bbclass)
+
+DEPENDS_kernel-module-zd1211rw += "zd1211-firmware"
+RDEPENDS_kernel-module-zd1211rw += "zd1211-firmware"