aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-kirkwood_2.6.31.bb
diff options
context:
space:
mode:
authorLeon Woestenberg <leon@sidebranch.com>2009-09-19 00:44:46 +0200
committerLeon Woestenberg <leon@sidebranch.com>2009-09-19 14:52:55 +0200
commitd9aac9ea22d75ef8ade18dbce3ef5c9bccaed3be (patch)
tree95943df3d0385aa2a5af99a82fef6f293ceead21 /recipes/linux/linux-kirkwood_2.6.31.bb
parentd5b4f3993861f3cbe6232f34281777f48c2c6c70 (diff)
downloadopenembedded-d9aac9ea22d75ef8ade18dbce3ef5c9bccaed3be.tar.gz
linux-kirkwood: Add kernel support for openrd-base.
Signed-off-by: Leon Woestenberg <leon@sidebranch.com>
Diffstat (limited to 'recipes/linux/linux-kirkwood_2.6.31.bb')
-rw-r--r--recipes/linux/linux-kirkwood_2.6.31.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes/linux/linux-kirkwood_2.6.31.bb b/recipes/linux/linux-kirkwood_2.6.31.bb
new file mode 100644
index 0000000000..b8270ed597
--- /dev/null
+++ b/recipes/linux/linux-kirkwood_2.6.31.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Linux Kernel for Marvell Kirkwood based devices"
+SECTION = "kernel"
+LICENSE = "GPL"
+
+COMPATIBLE_MACHINE = "openrd-base"
+
+# SheevaPlug still needs testing
+#COMPATIBLE_MACHINE = "(openrd-base|sheevaplug)"
+
+require linux.inc
+
+# Change MACHINE_KERNEL_PR in conf/machine/include/kirkwood.inc
+PV = "2.6.31"
+
+# last commit at the time of release of upstream v2.6.31
+SRCREV = "8cb424312d88810bb62edbeef42a510725ceb482"
+
+SRC_URI = "git://git.marvell.com/orion.git;protocol=git \
+ file://defconfig"
+
+# update machine types list for ARM architecture, only for machines that need it
+do_arm_mach_types_openrd-base() {
+ if test ${TARGET_ARCH} == arm; then
+ curl -o mach-types "http://www.arm.linux.org.uk/developer/machines/download.php" && \
+ cp mach-types arch/arm/tools/mach-types
+ fi
+}
+
+addtask arm_mach_types after do_patch before do_configure
+
+S = "${WORKDIR}/git"
+
+KERNEL_IMAGETYPE ?= "uImage"