aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-mtx-3_2.6.15.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux/linux-mtx-3_2.6.15.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/linux-mtx-3_2.6.15.bb')
-rw-r--r--recipes/linux/linux-mtx-3_2.6.15.bb59
1 files changed, 59 insertions, 0 deletions
diff --git a/recipes/linux/linux-mtx-3_2.6.15.bb b/recipes/linux/linux-mtx-3_2.6.15.bb
new file mode 100644
index 0000000000..e1613d6f60
--- /dev/null
+++ b/recipes/linux/linux-mtx-3_2.6.15.bb
@@ -0,0 +1,59 @@
+DESCRIPTION = "Linux kernel for MTX-3 (Surfbox3)"
+HOMEPAGE = "http://meshcube.org/meshwiki/"
+LICENSE = "GPL"
+KV = "${PV}"
+PR = "r11"
+inherit module-base kernel
+
+PROVIDES = "virtual/kernel"
+RDEPENDS = "mtd-utils"
+
+SRC_URI += "cvs://cvs:cvs@ftp.linux-mips.org/home/cvs;module=linux;tag=linux_2_6_15 \
+ file://defconfig-mtx-3"
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/linux-mtx-3-${PV}"
+
+S = "${WORKDIR}/linux"
+
+inherit kernel
+
+COMPATIBLE_MACHINE = "mtx-3"
+COMPATIBLE_HOST = "arm.*-linux"
+ARCH = "arm"
+KERNEL_OUTPUT = "arch/arm/zboot/images/mtx-3.flash.bin"
+KERNEL_IMAGETYPE = "zImage.flash"
+KERNEL_IMAGEDEST = "tmp"
+
+KERNEL_IMAGE_NAME = "kernel-${KV}-${MACHINE}_${BUILDNAME}"
+
+MTX_KERNEL_NON_PCI_OHCI = "no"
+
+PACKAGE_ARCH = "mtx-3"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconfig-mtx-3 ${S}/.config
+ if [ "x${MTX_KERNEL_NON_PCI_OHCI}" == "xyes" ]; then
+ echo "CONFIG_USB_NON_PCI_OHCI=y" >> ${S}/.config
+ fi
+}
+
+pkg_postinst_kernel() {
+if test "x$D" != "x"; then
+ exit 1
+else
+ if test -e /tmp/zImage.flash-${KV}; then
+ echo "*** flashing kernel ***"
+ flashcp -v /tmp/zImage.flash-${KV} /dev/mtd/2
+ echo "*** done. please reboot ***"
+ fi
+fi
+}
+
+FILES_kernel += " /tmp"
+
+do_deploy() {
+ install -d ${DEPLOY_DIR}/images
+ install -m 0644 arch/arm/zboot/images/mtx-3.flash.bin ${DEPLOY_DIR}/images/${KERNEL_IMAGE_NAME}.flash.bin
+ install -m 0644 arch/arm/zboot/images/mtx-3.flash.srec ${DEPLOY_DIR}/images/${KERNEL_IMAGE_NAME}.flash.srec
+ install -m 0644 arch/arm/zboot/images/mtx-3.srec ${DEPLOY_DIR}/images/${KERNEL_IMAGE_NAME}.ram.srec
+}