summaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-n1200_2.6.27-rc9+git.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux/linux-n1200_2.6.27-rc9+git.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/linux-n1200_2.6.27-rc9+git.bb')
-rw-r--r--recipes/linux/linux-n1200_2.6.27-rc9+git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/linux/linux-n1200_2.6.27-rc9+git.bb b/recipes/linux/linux-n1200_2.6.27-rc9+git.bb
new file mode 100644
index 0000000000..7674379a6b
--- /dev/null
+++ b/recipes/linux/linux-n1200_2.6.27-rc9+git.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Linux Kernel for the Thecus n1200"
+SECTION = "kernel"
+LICENSE = "GPL"
+PR = "r3"
+DEPENDS = "u-boot-mkimage-native"
+COMPATIBLE_MACHINE = "n1200"
+
+SRC_URI = "http://downloads.thecus.nas-central.org/N1200/Kernels/linux-2.6.27-foonas-git.tar.gz \
+ file://fw-install.patch;patch=1 \
+ file://defconfig"
+S = "${WORKDIR}/linux-2.6.27-foonas-git"
+
+export ARCH="powerpc"
+
+# Bootloader is not device tree aware
+KERNEL_OUTPUT = "${S}/arch/powerpc/boot/cuImage.thecus_n1200"
+
+require linux.inc
+
+do_configure() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+ ARCH=${ARCH} oe_runmake oldconfig
+}