summaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-omap-2.6.31
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-09-11 09:05:21 +0200
committerKoen Kooi <koen@openembedded.org>2009-09-11 09:05:21 +0200
commitd13e15663fb6ccd34dd7214178e3d1caf645179f (patch)
tree68655966318600adee8dff63a93e961bbef67b93 /recipes/linux/linux-omap-2.6.31
parent2b1928ff76811b5f4e734ddbf21aacdfcd54e68c (diff)
downloadopenembedded-d13e15663fb6ccd34dd7214178e3d1caf645179f.tar.gz
linux-omap: add 2.6.31
Diffstat (limited to 'recipes/linux/linux-omap-2.6.31')
-rw-r--r--recipes/linux/linux-omap-2.6.31/dss2/0001-OMAP3-Enable-DSS2-for-OMAP3EVM-board.patch42
-rw-r--r--recipes/linux/linux-omap-2.6.31/dss2/0004-OMAP-Add-VRAM-manager.patch34
2 files changed, 30 insertions, 46 deletions
diff --git a/recipes/linux/linux-omap-2.6.31/dss2/0001-OMAP3-Enable-DSS2-for-OMAP3EVM-board.patch b/recipes/linux/linux-omap-2.6.31/dss2/0001-OMAP3-Enable-DSS2-for-OMAP3EVM-board.patch
index 9a4ea8b9ad..0167fe2a55 100644
--- a/recipes/linux/linux-omap-2.6.31/dss2/0001-OMAP3-Enable-DSS2-for-OMAP3EVM-board.patch
+++ b/recipes/linux/linux-omap-2.6.31/dss2/0001-OMAP3-Enable-DSS2-for-OMAP3EVM-board.patch
@@ -1,20 +1,17 @@
-From 798f9b1bc478c7ded724fc190c65e413c2401314 Mon Sep 17 00:00:00 2001
From: Vaibhav Hiremath <hvaibhav@ti.com>
-Date: Tue, 11 Aug 2009 15:52:04 +0530
-Subject: [PATCH 1/5] OMAP3: Enable DSS2 for OMAP3EVM board
+Date: Thu, 10 Sep 2009 15:11:34 +0000 (+0530)
+Subject: OMAP3: Enable DSS2 for OMAP3EVM board
+X-Git-Url: http://arago-project.org/git/people/?p=vaibhav%2Fti-psp-omap-video.git;a=commitdiff_plain;h=1022536cf655419eac21299eac837f57f8f72eef
+
+OMAP3: Enable DSS2 for OMAP3EVM board
Tested -
- Validated all three outut interfaces (LCD, DVI and TV)
+
TODO:
- - Support for Backlight control range (0 - 100)
- Enable selection for both S-Video and Composite TV out
- DVI color (VPLL2_DEV_GRP should be equal to 0x7)
-
-Signed-off-by: Vaibhav Hiremath <hvaibhav@ti.com>
---
- arch/arm/configs/omap3_evm_defconfig | 51 +++++++-
- arch/arm/mach-omap2/board-omap3evm.c | 234 ++++++++++++++++++++++++++++++++--
- 2 files changed, 273 insertions(+), 12 deletions(-)
diff --git a/arch/arm/configs/omap3_evm_defconfig b/arch/arm/configs/omap3_evm_defconfig
index d5ff477..ba395a2 100644
@@ -79,7 +76,7 @@ index d5ff477..ba395a2 100644
#
diff --git a/arch/arm/mach-omap2/board-omap3evm.c b/arch/arm/mach-omap2/board-omap3evm.c
-index c0cb29d..0bc26b3 100644
+index 35f6075..5bc4bfe 100644
--- a/arch/arm/mach-omap2/board-omap3evm.c
+++ b/arch/arm/mach-omap2/board-omap3evm.c
@@ -22,6 +22,7 @@
@@ -271,9 +268,9 @@ index c0cb29d..0bc26b3 100644
+ },
+};
- static struct omap_uart_platform_data omap3_evm_uart_config __initdata = {
- .enabled_uarts = ((1 << 0) | (1 << 1) | (1 << 2)),
-@@ -143,6 +313,14 @@ static int omap3evm_twl_gpio_setup(struct device *dev,
+ static struct twl4030_hsmmc_info mmc[] = {
+ {
+@@ -139,6 +309,14 @@ static int omap3evm_twl_gpio_setup(struct device *dev,
* the P2 connector; notably LEDA for the LCD backlight.
*/
@@ -288,7 +285,7 @@ index c0cb29d..0bc26b3 100644
/* TWL4030_GPIO_MAX + 1 == ledB (out, active low LED) */
gpio_leds[2].gpio = gpio + TWL4030_GPIO_MAX + 1;
-@@ -194,6 +372,47 @@ static struct twl4030_madc_platform_data omap3evm_madc_data = {
+@@ -190,6 +368,47 @@ static struct twl4030_madc_platform_data omap3evm_madc_data = {
.irq_line = 1,
};
@@ -336,7 +333,7 @@ index c0cb29d..0bc26b3 100644
static struct twl4030_platform_data omap3evm_twldata = {
.irq_base = TWL4030_IRQ_BASE,
.irq_end = TWL4030_IRQ_END,
-@@ -203,6 +422,8 @@ static struct twl4030_platform_data omap3evm_twldata = {
+@@ -199,6 +418,8 @@ static struct twl4030_platform_data omap3evm_twldata = {
.madc = &omap3evm_madc_data,
.usb = &omap3evm_usb_data,
.gpio = &omap3evm_gpio_data,
@@ -345,7 +342,7 @@ index c0cb29d..0bc26b3 100644
};
static struct i2c_board_info __initdata omap3evm_i2c_boardinfo[] = {
-@@ -223,15 +444,6 @@ static int __init omap3_evm_i2c_init(void)
+@@ -219,15 +440,6 @@ static int __init omap3_evm_i2c_init(void)
return 0;
}
@@ -361,20 +358,24 @@ index c0cb29d..0bc26b3 100644
static void ads7846_dev_init(void)
{
if (gpio_request(OMAP3_EVM_TS_GPIO, "ADS7846 pendown") < 0)
-@@ -287,11 +499,10 @@ static void __init omap3_evm_init_irq(void)
- }
+@@ -275,7 +487,6 @@ struct spi_board_info omap3evm_spi_board_info[] = {
+ };
static struct omap_board_config_kernel omap3_evm_config[] __initdata = {
- { OMAP_TAG_LCD, &omap3_evm_lcd_config },
};
+ static void __init omap3_evm_init_irq(void)
+@@ -289,7 +500,7 @@ static void __init omap3_evm_init_irq(void)
+ }
+
static struct platform_device *omap3_evm_devices[] __initdata = {
- &omap3_evm_lcd_device,
+ &omap3_evm_dss_device,
&omap3evm_smc911x_device,
};
-@@ -314,6 +525,7 @@ static void __init omap3_evm_init(void)
+@@ -310,6 +521,7 @@ static void __init omap3_evm_init(void)
usb_musb_init();
usb_ehci_init(EHCI_HCD_OMAP_MODE_PHY, true, true, 57, 61);
ads7846_dev_init();
@@ -382,6 +383,3 @@ index c0cb29d..0bc26b3 100644
}
static void __init omap3_evm_map_io(void)
---
-1.6.2.4
-
diff --git a/recipes/linux/linux-omap-2.6.31/dss2/0004-OMAP-Add-VRAM-manager.patch b/recipes/linux/linux-omap-2.6.31/dss2/0004-OMAP-Add-VRAM-manager.patch
index 13fe0b0234..47eab0fa7d 100644
--- a/recipes/linux/linux-omap-2.6.31/dss2/0004-OMAP-Add-VRAM-manager.patch
+++ b/recipes/linux/linux-omap-2.6.31/dss2/0004-OMAP-Add-VRAM-manager.patch
@@ -1,7 +1,9 @@
-From cb8ce54283e64bd30636b7bcd2d7bb4e200825d2 Mon Sep 17 00:00:00 2001
From: Tomi Valkeinen <tomi.valkeinen@nokia.com>
-Date: Fri, 7 Aug 2009 12:01:55 +0300
-Subject: [PATCH 04/18] OMAP: Add VRAM manager
+Date: Fri, 7 Aug 2009 09:01:55 +0000 (+0300)
+Subject: OMAP: Add VRAM manager
+X-Git-Url: http://arago-project.org/git/people/?p=vaibhav%2Fti-psp-omap-video.git;a=commitdiff_plain;h=9e5a02f69fe2261ac928aa956add6f1c9f48386d
+
+OMAP: Add VRAM manager
Add a Video RAM manager for OMAP 2 and 3 platforms. VRAM manager is used
to allocate large continuous blocks of SDRAM or SRAM. The features VRAM
@@ -20,33 +22,20 @@ and boot parameter overrides kernel config and board file.
Signed-off-by: Tomi Valkeinen <tomi.valkeinen@nokia.com>
---
- arch/arm/mach-omap2/io.c | 2 +
- arch/arm/plat-omap/include/mach/vram.h | 63 +++
- arch/arm/plat-omap/sram.c | 8 +
- drivers/video/Kconfig | 1 +
- drivers/video/Makefile | 1 +
- drivers/video/omap2/Kconfig | 2 +
- drivers/video/omap2/Makefile | 1 +
- drivers/video/omap2/vram.c | 655 ++++++++++++++++++++++++++++++++
- 8 files changed, 733 insertions(+), 0 deletions(-)
- create mode 100644 arch/arm/plat-omap/include/mach/vram.h
- create mode 100644 drivers/video/omap2/Kconfig
- create mode 100644 drivers/video/omap2/Makefile
- create mode 100644 drivers/video/omap2/vram.c
diff --git a/arch/arm/mach-omap2/io.c b/arch/arm/mach-omap2/io.c
-index 49199a3..f837063 100644
+index 4a08ad3..e5dd736 100644
--- a/arch/arm/mach-omap2/io.c
+++ b/arch/arm/mach-omap2/io.c
-@@ -32,6 +32,7 @@
- #include <mach/sram.h>
+@@ -33,6 +33,7 @@
#include <mach/sdrc.h>
#include <mach/gpmc.h>
+ #include <mach/serial.h>
+#include <mach/vram.h>
#ifndef CONFIG_ARCH_OMAP4 /* FIXME: Remove this once clkdev is ready */
#include "clock.h"
-@@ -240,6 +241,7 @@ void __init omap2_map_common_io(void)
+@@ -246,6 +247,7 @@ void __init omap2_map_common_io(void)
omap2_check_revision();
omap_sram_init();
omapfb_reserve_sdram();
@@ -124,7 +113,7 @@ index 0000000..fe72f81
+
+#endif
diff --git a/arch/arm/plat-omap/sram.c b/arch/arm/plat-omap/sram.c
-index 5eae787..c9b89cd 100644
+index 925f647..cda311b 100644
--- a/arch/arm/plat-omap/sram.c
+++ b/arch/arm/plat-omap/sram.c
@@ -28,6 +28,7 @@
@@ -849,6 +838,3 @@ index 0000000..634ce23
+ omap_vram_sram_start = start;
+ omap_vram_sram_size = size;
+}
---
-1.6.2.4
-