aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-omap-multi-psp_2.6.32.bb
diff options
context:
space:
mode:
authorKoen Kooi <k-kooi@ti.com>2010-02-09 12:04:03 +0100
committerKoen Kooi <koen@openembedded.org>2010-04-12 19:43:18 +0200
commitbb74bdac2d9bab9b44a9a79586a47e25b7ab8b34 (patch)
tree370119fd528b57caa157e9d75e94aec2af1c88ed /recipes/linux/linux-omap-multi-psp_2.6.32.bb
parent6499b64e6fd59e28ed915f06f0c7b6c9b897e891 (diff)
downloadopenembedded-bb74bdac2d9bab9b44a9a79586a47e25b7ab8b34.tar.gz
linux-omap-multi-psp 2.6.32: example recipe on how to use multi-kernel.inc
Diffstat (limited to 'recipes/linux/linux-omap-multi-psp_2.6.32.bb')
-rw-r--r--recipes/linux/linux-omap-multi-psp_2.6.32.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes/linux/linux-omap-multi-psp_2.6.32.bb b/recipes/linux/linux-omap-multi-psp_2.6.32.bb
new file mode 100644
index 0000000000..e1d662c7bf
--- /dev/null
+++ b/recipes/linux/linux-omap-multi-psp_2.6.32.bb
@@ -0,0 +1,46 @@
+require multi-kernel.inc
+
+FILESPATHPKG_prepend = "linux-omap-psp-2.6.32:"
+
+DESCRIPTION = "Linux kernel for OMAP processors"
+KERNEL_IMAGETYPE = "uImage"
+
+COMPATIBLE_MACHINE = "beagleboard|omap3evm|am3517-evm|omap3-touchbook"
+
+SRCREV = "06733a907b777f7dca21b2d44e36b6c4afbe01fe"
+
+# The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc
+MACHINE_KERNEL_PR_append = "+gitr${SRCREV}"
+
+SRC_URI += "git://arago-project.org/git/people/sriram/ti-psp-omap.git;protocol=git;branch=master \
+ file://0005-ARM-OMAP-add-support-for-TCT-Zippy-to-Beagle-board.patch;patch=1 \
+ file://0006-ARM-OMAP-Make-beagle-u-boot-partition-writable.patch;patch=1 \
+ file://0007-ASoC-enable-audio-capture-by-default-for-twl4030.patch;patch=1 \
+ file://0009-MTD-NAND-omap2-proper-fix-for-subpage-read-ECC-error.patch;patch=1 \
+ file://dss2/0015-OMAP-DSS-Add-DSS2-support-for-Beagle.patch;patch=1 \
+ file://dss2/0016-video-add-timings-for-hd720.patch;patch=1 \
+ file://holes.patch;patch=1 \
+ file://no-mmc-spew.patch;patch=1 \
+ file://beagleboard/0001-beagleboard-omap3_-foo-_rate_table-omap35x_-foo.patch;patch=1 \
+ file://beagleboard/0001-board-omap3beagle-prepare-for-DM3730-based-Beaglebo.patch;patch=1 \
+ file://0001-board-omap3touchbook-make-it-build-against-TI-linux.patch;patch=1 \
+ file://defconfig"
+
+SRC_URI_append_beagleboard = " file://logo_linux_clut224.ppm \
+"
+
+addtask quiltfixup before do_patch after do_unpack
+do_quiltfixup() {
+ rm ${S}/.pc -rf
+}
+
+S = "${WORKDIR}/git"
+
+do_install_append() {
+ install -d ${D}/boot
+ install -m 0644 Documentation/arm/OMAP/DSS ${D}/boot/
+}
+
+PACKAGES =+ "omap-dss-doc"
+FILES_omap-dss-doc = "/boot/DSS"
+