aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-omap-psp_2.6.31.bb
diff options
context:
space:
mode:
authorKoen Kooi <k-kooi@ti.com>2009-09-24 14:52:55 +0200
committerKoen Kooi <koen@openembedded.org>2009-09-25 11:16:30 +0200
commit02b33c980cd6ec904405f78a547a65fb070d4b97 (patch)
tree36c6b5dffcfcd8f3ee66e1957031936029394bcb /recipes/linux/linux-omap-psp_2.6.31.bb
parentf750244ae88315ae3ee49af9495ad7d1e38abb92 (diff)
downloadopenembedded-02b33c980cd6ec904405f78a547a65fb070d4b97.tar.gz
linux-omap-psp: add 2.6.31rc7 recipe
Diffstat (limited to 'recipes/linux/linux-omap-psp_2.6.31.bb')
-rw-r--r--recipes/linux/linux-omap-psp_2.6.31.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/linux/linux-omap-psp_2.6.31.bb b/recipes/linux/linux-omap-psp_2.6.31.bb
new file mode 100644
index 0000000000..6828d52146
--- /dev/null
+++ b/recipes/linux/linux-omap-psp_2.6.31.bb
@@ -0,0 +1,28 @@
+require linux.inc
+
+DESCRIPTION = "Linux kernel for OMAP processors"
+KERNEL_IMAGETYPE = "uImage"
+
+COMPATIBLE_MACHINE = "omap3evm|omap3517-evm"
+
+SRCREV = "9cf7a18fe227717dcc08163100dacd579de48e0c"
+
+PV = "2.6.30+2.6.31rc7"
+# The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc
+PR_append = "+gitr${SRCREV}"
+
+SRC_URI = "git://arago-project.org/git/people/sriram/ti-psp-omap.git;protocol=git;branch=staging \
+ file://0001-implement-TIF_RESTORE_SIGMASK-support-and-enable-the.patch;patch=1 \
+ file://defconfig"
+
+S = "${WORKDIR}/git"
+
+do_install_append() {
+ install -d ${D}/boot
+ install -m 0644 Documentation/arm/OMAP/DSS ${D}/boot/
+}
+
+PACKAGES =+ "omap-dss-doc"
+FILES_omap-dss-doc = "/boot/DSS"
+
+