aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-openmoko-2.6.29_git.bb
diff options
context:
space:
mode:
authorMike Westerhof <mwester@dls.net>2009-04-15 20:01:10 -0500
committerMike Westerhof <mwester@dls.net>2009-04-15 20:01:10 -0500
commitfb7eba513b2d59c33163bd380019a4cabc8b6782 (patch)
treef6ba44e483f05eb98a7f3619fe5ecb4785f5c682 /recipes/linux/linux-openmoko-2.6.29_git.bb
parenta91ef39c62f371125a92098d4fbd45056122c384 (diff)
downloadopenembedded-fb7eba513b2d59c33163bd380019a4cabc8b6782.tar.gz
Openmoko: linux-openmoko-2.6.29 - commit new recipe tied to upstream kernel
git repo, which is currently at 2.6.29-rc3 + Openmoko patches. Note that the preferred kernel remains unchanged; select this kernel via local.conf.
Diffstat (limited to 'recipes/linux/linux-openmoko-2.6.29_git.bb')
-rw-r--r--recipes/linux/linux-openmoko-2.6.29_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/linux/linux-openmoko-2.6.29_git.bb b/recipes/linux/linux-openmoko-2.6.29_git.bb
new file mode 100644
index 0000000000..19423509e8
--- /dev/null
+++ b/recipes/linux/linux-openmoko-2.6.29_git.bb
@@ -0,0 +1,31 @@
+require linux.inc
+require linux-openmoko.inc
+
+DESCRIPTION_${PN} = "Linux ${KERNEL_RELEASE} kernel for the Openmoko Neo GSM Smartphones"
+
+# NOTE: This recipe is tied to an upstream git repo; the KERNEL_VERSION must match the
+# the kernel version string as built, otherwise depmod will silently fail when building
+# the image itself. KERNEL_RELEASE should match the kernel version in the recipe name.
+# This may have to be adjusted as the upstream git repository changes!
+KERNEL_RELEASE = "2.6.29"
+KERNEL_VERSION = "2.6.29-rc3"
+
+OEV = "oe1"
+PV = "${KERNEL_RELEASE}-${OEV}+gitr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "\
+ git://git.openmoko.org/git/kernel.git;protocol=git;branch=andy-tracking \
+ file://fix-install.patch;patch=1 \
+ file://defconfig-oe.patch \
+"
+S = "${WORKDIR}/git"
+
+CONFIG_NAME_om-gta01 = "gta01_moredrivers_defconfig"
+CONFIG_NAME_om-gta02 = "gta02_packaging_defconfig"
+CONFIG_NAME_om-gta03 = "gta03_defconfig"
+
+do_configure_prepend() {
+ install -m 644 ./arch/arm/configs/${CONFIG_NAME} ${WORKDIR}/defconfig-oe
+ cat ${WORKDIR}/defconfig-oe.patch | patch -p0 -d ${WORKDIR}
+}